Page 2 of 2

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Thu Apr 28, 2011 4:13 pm
by fb_joel
NXTLukas, ah good to hear. The wired Xbox 360 Controller should be quite perfect for the game so it's a good choice if you want to go that route. :)

ilenburg, I'm afraid there's not much help I can give on this... I suspect it's the adapter that's causing trouble. Does it work in Control Panel / Gamepads properly? Also, have you tried the Xbox 360 Controller emulator? It could be worth a shot.

(I moved the Linux posts to their own thread.)

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Fri Jul 22, 2011 5:21 pm
by NXTLukas
Now I already have my 360-controller for some time and it works great. But I experienced, that it was harder playing a level with the controller, than it is with Magic Mouse and keyboard. For example the arrow shooting is not that precise, because of the limited movement of the sticks. You can't make a full turn. This also makes it hard making objects. I'd need a controller with a touchpad. Do you think, this would be possible? Or finally a way to use two mice and keyboards.
At least the problem will be solved in Trine 2 with its Online Co-Op :)

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Mon Jul 25, 2011 12:34 pm
by fb_joel
I'm not sure I understand the problem with the gamepad... What do you mean by "You can't make a full turn"? The 360 Controller should work quite well so I'm curious if there's perhaps something else going on, like a small bug in the game or in the configs. It probably isn't possible to combine a gamepad and a touchpad at the same time, but I haven't tried this myself yet...

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Wed Oct 12, 2011 1:53 am
by RPG Hacker
Hi there!

I just registered here to confirm that the XBox 360 Controller Emulator does indeed work very well with this game. I have three controllers connected to my PC: A LinQ Dualshock 2 Controller and two Wii Classic Controllers (connected through a Mayflash adapter). None of them worked with Trine natively, but all of them work using the XBox 360 Controller Emulator.

Maybe you should add a link to the emulator on your Gamepad Page? This would make it easier for players with the same problem. It took me a while to find the emulator.

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Wed Oct 12, 2011 7:10 pm
by fb_joel
Ah, good to hear. Yes, I plan to revamp our whole support site/pages in time for Trine 2 launch, and we'll make the Trine gamepad help better then as well. Good to hear the emulator works though. :)

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Mon Oct 24, 2011 5:00 am
by PugPug
fb_joel wrote:Here's a new gamepad guide we've made:
http://trine-thegame.com/help/trinegamepads.php

It might help explain some things. Regarding Thief's attack - do you mean her arrow shooting? That's controlled by the right thumbstick which is defined on the very last page of the controls (see the above link). I hope it helps.


No, he means the thief attack option is actually missing from the configuration menu for gamepads. It only appears for mouse + keyboard. All that shows up on the Thief page is Thief Grappling Hook, Thief Normal Arrow and Thief Fire Arrow. If you switch to the Mouse + Keyboard configuration it adds a line; Thief Attack.

On the Knight, Knight Throw disappears if you move to configure a gamepad. On the Wizard, everything is there.

It appears you cannot bind Thief Attack to a gamepad without manually editing a config file. Is this true?

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Mon Oct 24, 2011 5:08 am
by PugPug
Here is a video I made to demonstrate the (apparent) bug. I left the video as unlisted (only viewable if you have the URL) so it doesn't broadcast the problem to the world at large.

http://www.youtube.com/watch?v=z2r33Pmh9Jo

I can use the right stick to shoot an arrow to the left, but if I point it to the right I get a grappling hook. And even though button 3 is bound to fire a normal arrow, it only does the grappling hook. So basically I can only shoot to the left.

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Mon Oct 24, 2011 7:49 pm
by PugPug
I checked out the config file itself and saw that thief attack is secretly bound to something like "any axis." I managed to fix the issue by going into the game and unbinding normal arrow and fire arrow completely, and binding grappling hook to only a button (no axis). Now I can fire an arrow in any direction by tapping that direction on the joystick.

Though I've gathered that the normal arrow bind may not actually be to fire a normal arrow. Rather, to switch to the normal arrow. I haven't progressed far enough to get a fire arrow attack yet. In that eventuality, I just bound a button to Next Weapon.

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Mon Oct 24, 2011 11:08 pm
by fb_joel
Thanks (and sorry). I'll have to check if this is indeed a bug or some weird "as designed" issue (which I think it is, for some reason).

What gamepad are you using?

We are currently configuring gamepads for Trine 2 and I hope that we'll be able to update Trine 1 after the launch of the sequel, and have it support gamepads a little better as well. (Of course this will take some time, even up to early next year, so it won't help just yet.)

The Thief's fire/normal buttons are indeed just a change weapon command basically, only the actual attack (right thumbstick default) is used to execute it.

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Thu Oct 27, 2011 12:21 pm
by PugPug
I think it is designed, because when you have a mouse, you can click in the direction you want the arrow to fire. With a gamepad, your only option is to move a joystick. Moving the joystick aims, and letting it snap back into position fires. The problem arises when something else is also bound to that joystick, which it is by default.

By default, Grappling Hook is bound to Joy-Throttle Down and Joy-Rudder Right. On my gamepad that's right and down on the right analog stick, respectively. So when I tried to fire an arrow to the right, I would get a grappling hook instead.

There's no reason for the grappling hook to be bound to an axis, as I don't think it can be aimed. You can choose to fire it to the left or right while hanging by using the left or right move button, but you cannot aim it vertically.

I'm using the Logitech Dual Action. It's modeled after the Playstation 3 controller.

I had a similar problem with the Wizard, but was able to figure that out before coming here. Draw and Levitate are both bound to Joy-Throttle Down and Joy-Rudder Right by default, just like the grappling hook. And again, these commands cannot be aimed. All those commands do is activate that mode while the button is held down, allowing you to move the cursor with something else. So by default moving the joystick simply activated levitate/draw, without actually moving the cursor. I had to bind levitate/draw to separate buttons and bind the X and Y axes to the joystick.

By default axis x and axis y are bound to axis_rx and axis_ry, which aren't used by my gamepad at all.

My left joystick is just joy-left, joy-right, joy-up and joy-down. My directional pad is joy-pov-left, joy-pov-right, joy-pov-up and joy-pov-down.

On my right joystick, Trine registers it as follows:

Left: joy-throttle-up
Right: joy-throttle-down
Up: joy-rudder-left
Down: joy-rudder right

I'm just going to post what I came up with that works:

joystick_x_axis = axis_throttle
joystick_y_axis = axis_rudder

controller_type = 105
camera_move_forward = joy-up
camera_move_backward = joy-down
camera_move_left = joy-left,joy-pov-left
camera_move_right = joy-right,joy-pov-right
change_next_weapon = joy-but-8
quit = joy-but-5
screenshot = f11
console_toggle = f8
execute = joy-but-6
run_script_20 = joy-pov-up
run_script_21 = joy-pov-down
wizard_break_object = joy-but-3,joy-but-4
wizard_draw_levitate_1 = joy-but-7
wizard_draw_levitate_2 = joy-but-5

thief_attack_current_weapon = joy-throttle-any,joy-rudder-any (not in game options, but here's the bind nonetheless)
thief_use_rope = joy-but-4
thief_ninja_time = joy-but-2
warrior_attack_current_weapon = joy-but-3
warrior_charge = joy-but-4
warrior_shield_throw = joy-throttle-any,joy-rudder-any (same as thief attack I expect, though I haven't encountered this ability in the game yet)
warrior_object_pickup = joy-but-2
open_upgrade = joy-but-9
jump = joy-but-1
open_pause_menu = joy-but-10
menu_select = joy-but-2
menu_special_1 = joy-but-1
menu_special_2 = joy-but-3
binds_v106 = 1

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Fri Oct 28, 2011 3:00 am
by fb_joel
Ah, makes sense. Just to confirm, now it works as you like?

Edit: Great. :) Sorry it was more difficult than it really needed to be.

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Fri Oct 28, 2011 9:50 pm
by PugPug
Yup, no more problems.

Re: Trine gamepad controllers configuration tips/troubleshoo

Posted: Mon Aug 20, 2012 1:08 am
by madwoodee
I've having trouble getting my wired xbox360 controller to work (gamestop brand).

I am playing Trine from Steam, so I assume its the latest version. Trine detects the controller, but will not detect any input. Can't remap buttons, and it does not work once in game P2 just sits there no matter what I push. Vista x64 says its working perfectly, and other games work fine with it.

I have tried the emulator, and using 1.07, but nothing seems to work. Any help?