Page 1 of 1

Trine won't start with patch 1.05? [Resolved]

Posted: Sun Nov 22, 2009 9:26 pm
by paul_cze

first off thanks Joel who manually activated my account : ).

I bought Trine today here: ... 76-13.html (first game I bought here).

I downloaded it, installed it along with the bonuses, ran it, activated it, everything went smooth, the game worked perfectly.

Then I realized that it is probably not updated version, so I went to that webpage above and downloaded the patch there (1.05).
It installs correctly, everything seems ok.
I run the game after the installation of the patch and here is what happens:

Launcher appears.I click Launch.Process trine.exe appears in task manager for about 5-8 seconds, always taking 50% cpu.Then it vanishes and the game does not run. (it ran perfectly before patching it!).

There is no error message in event viewer.
I tried to reinstall the game and try again, but I got the same problem.
I have this PC:

Core2Duo 3.16ghz
2 giga ram
WinXP SP3 nLited

I have installed: latest PhysX drivers, forceware 190.62, visualc++ runtime, windows media codecs, latest version of DirectX..simply, everything I should need.

Any idea what is the problem? Why the game works well without the patch and will not run after the patch? (my guess would be the Tages DRM is a culprit, but I don't know).

Applications that are running when I run the game: client
Avast antivirus (I tried to disable it and it did not help).

I am really irritated when things that should work don't work and I have no idea WHY.
I hope someone here will have an idea.I can provide any info you could need in order to help, if the above is not enough.


Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 1:17 am
by Mr. ShadowStealer
By any chance, did you install new graphic card drivers between when you launched the unpatched Trine and when you launched patched Trine?

I had this exact same problem with Unreal Tournament 3. The game ran just fine, then I updated my graphic card drivers and BAM it just showed the splash screen, stayed there for a while and then it just quit without any sort of error message.

So... If you updated your graphic card drivers, uninstall them completelly, do a restart (warning: this will cause your screen resolution drop to 640x480 so make sure to take a picture of your desktop icon arragement. ;)) then reinstall the latest drivers and it should help.

If you just installed newer drivers on top of the older ones, this behavious could be explaned by that. But if you didn't install new graphic card drivers then at the moment I don't have a clue what could cause this.

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 2:05 am
by paul_cze
Hello, I do not think this is it - I have 190.62 for about a month and I did not reinstall them at any time during my problems with Trine. (I bought Trine today!).
I have currently 317 games installed and every single one works perfectly except for patched Trine : (

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 2:23 pm
by fb_joel
Sorry I didn't get here last night, was a bit too tired.

Anyhow, did you download the patch from the official website, i.e. ? If so, then that's the problem... The patch doesn't work with the GamesPlanet version of the game. I have updated the info on the page now, sorry for not having it there earlier.

GamesPlanet has their version of the patch at ... -1376.html

I hope this helps. Let me know if it's the GamesPlanet version of the patch that doesn't work, I couldn't quite figure out if you had actually downloaded that and not the one on our own site, then that's a different issue... (Although I may have to recommend that you re-download the whole game and then apply the patch.)

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 3:37 pm
by paul_cze
Hello Joel,

I have written "so I went to that webpage above and downloaded the patch there (1.05)." - by the webpage above I meant the gamesplanet one.

I downloaded the correct patch and applied it.

Sequence of events:

1)Downloaded game from gamesplanet

2)Installed the game from gamesplanet

3)Ran the game, activated it with serial received via email, activation sucessfull, game fires up and works perfectly

4)Quit game, realized to check if there is patch, download patch from gamesplanet and install it, everything seems ok

5)Fire up game, it does not work, process trine.exe terminates itself after several seconds.

Then I tried to uninstall the game completely, install it again and then install the patch immediately without firing the game up first - same thing, still does not work.

Maybe there is some service that the game needs running or something? I have WinXP SP3 optimized, unnecesarry services shut down, etc..
But the game works without the patch, so I really do not understand it.

Again, I can provide any info necesarry to solve it.

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 4:32 pm
by fb_joel
Ok thanks... It does sound a bit weird. I will test this myself today within a few hours and see what happens, i.e. if it's a general bug with the patch or something else.

The good news is that we'll be able to solve this one way or another, hopefully later today. I'll let you know how my own test goes.

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 6:16 pm
by paul_cze
Thanks for the great support!

Unfortunately I suspect the problem will be limited to my PC, because I asked my friend who bought the game on the same day from the same webpage, and for him the game works correctly with the patch.
Though I really cannot imagine what could cause it.If you need screenshot of what services I am running, dxdiag log, etc, I can provide it.Again, thanks!

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 6:35 pm
by fb_joel
Well, the "good" news is that I got the same problem. Doesn't run after the patch, without it ran fine.

I did notice that the updated trine.exe wants to do some system modifications, as my F-Secure warned me about that and denied it. I manually allowed it and tried again but it didn't work. So perhaps you can try checking your antivirus software and see if there's anything there. I'll try to figure it out in the meantime as well, and come back with a solution in a couple of hours...

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 6:38 pm
by paul_cze
That's interesting.I wonder why it worked for my friend..though I have no idea what system is he running or any idea what his PC is like.

When I tried it before, I tried to disable Avast resident protection, it did not help.I do no have any other firewall or antispyware or program like that running - only Avast.

Re: Trine won't start with patch 1.05?

Posted: Mon Nov 23, 2009 6:53 pm
by fb_joel
Ok. I have sent you an email, let's continue there. If anyone else gets this same problem, send me an email and we'll figure it out.

Edit: GamesPlanet has fixed the patch - now it works (for me at least). You need to download the patch again on the GamesPlanet site though.

Re: Trine won't start with patch 1.05? [Resolved]

Posted: Fri Nov 27, 2009 9:26 pm
by machine
I installed the 1.05 GamesPlanet patch and the game wont' start.

Update: Using the updated version of the 1.05 patch fixed the problem. Thanks, Joel.

Re: Trine won't start with patch 1.05? [Resolved]

Posted: Sat Nov 28, 2009 1:31 am
by fb_joel
Good to hear. :)