Linux: No sound in Trine on Ubuntu 10.10

Technical support for the Linux and Mac platforms for all Trine games.
nickspoon
Posts: 1
Joined: Wed Apr 13, 2011 4:28 pm

Linux: No sound in Trine on Ubuntu 10.10

Postby nickspoon » Wed Apr 13, 2011 4:34 pm

Just downloaded Trine from the Frozenbyte bundle (excellent deal by the way, makes up for missing Humble Bundle 2 a little). I downloaded and ran the installer, installing Trine to my home directory; it ran okay, but with no sound. Looking in the log file, there are a whole bunch of messages like this:

ERROR: OpenAL error at ../sound/openal/SoundLib.cpp:134 : Illegal call.
ERROR: OpenAL error at ../sound/openal/SoundLib.cpp:130 : Illegal call.
ERROR: OpenAL error at ../sound/openal/SoundLib.cpp:134 : Illegal call.
ERROR: OpenAL error at ../sound/openal/SoundLib.cpp:185 : Illegal call.
ERROR: OpenAL error at ../sound/openal/SoundLib.cpp:185 : Illegal call.
ERROR: OpenAL error at ../sound/openal/SoundLib.cpp:185 : Illegal call.

I noticed that Trine is using its own local copy of libopenal.so.1 (under lib32 for my 32-bit system). I renamed it to libopenal.so.1.old so that Trine would use the system version of OpenAL, and now the sound works. Just a heads up to anyone who finds that they don't get any sound - I'm using PulseAudio 0.9.22, for the record.

Hennes
Posts: 3
Joined: Sun Apr 10, 2011 11:10 pm

Re: No sound in Trine on Ubuntu 10.10

Postby Hennes » Thu Apr 14, 2011 12:24 am

Thanks for the post.

Same on openSUSE 11.4 64bit.

Just rename "libopenal.so.1" into "libopenal.so.1.old" in the "lib64" folder an the sound works perfectly.

erik777
Posts: 2
Joined: Thu Apr 14, 2011 4:27 am

Re: No sound in Trine on Ubuntu 10.10

Postby erik777 » Thu Apr 14, 2011 4:29 am

Thanks! Ditto for Fedora 14. Had to change in trine/lib64 in my case for obvious reasons.

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: No sound in Trine on Ubuntu 10.10

Postby fb_joel » Fri Apr 15, 2011 10:15 am

Thanks for posting this guys, much appreciated! Seems like it already helped a lot of people. :)
// Joel, Frozenbyte team


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 0 guests