Page 1 of 1

Trine2 on Slackware

Posted: Sun Sep 22, 2013 8:40 pm
by ZeD
Hi.

I'm running a slackware machine (using -current, 64bit + AlienBOB's multilib packages[0]).

I purchased Trine2 throug the Humble Bundle 9 package; I downloaded and scompatted the .tar.gz, but, when I tried to launch the game, I was stuck. Mumbling with the command line I found this:

Code: Select all

$ ./bin/trine2_linux_launcher_32bit
./bin/trine2_linux_launcher_32bit: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory
$ ldd bin/trine2_linux_* | grep not | sort -u
        libCgGL.so => not found
        libCg.so => not found
        libopenal.so.1 => not found
        libPhysXLoader.so.1 => not found
        libSDL-1.3.so.0 => not found
        libselinux.so.1 => not found
        libwrap.so.0 => not found


AFAIK there are some .so object directly distribuited in the tar.gz

Code: Select all

$ ls lib/lib32/
libCgGL.so  libCg.so  libPhysXCooking.so  libPhysXCooking.so.1  libPhysXCore.so  libPhysXCore.so.1  libPhysXLoader.so  libPhysXLoader.so.1  libSDL-1.3.so.0


so, ignoring libCgCL, libCg, libPhysXLoader and libSDL, I found I need libopenal, libselinux and libwrap.

It's possible for you to distribute also these packages in the tar.gz? Alternatively, can you help me building these libraries? while libopenal should be easy doable, I just have no idea what libwrap is, and where I can get it, and for selinux... AFAIK it's not just a simple .so object...

Are these libraries strictly needed to play trine? Can you guys help me?

Thanks

[0] http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:multilib

Re: Trine2 on Slackware

Posted: Wed Sep 25, 2013 9:54 am
by whoami
Hello,
I had similar problems on Slackware 14.0. The only thing you need to install is openal, which you can get from slackbuilds.org, but you need a 32bit slackware in order to build the package. Concerning libwrap and libselinux, it seems that those were accidentially linked to the launcher executable, they are not needed! There was a similar problem described here: viewtopic.php?f=17&t=14639
The solution mentioned in this thread, linking one of the existing libraries under lib to libselinux.so.1 and libwrap.so.0 respectively works well for me. You also can use the launcher-executable from Trine2 Collectors edition, if you own that too.
@Frozenbyte Team: Thanks again for making the DRM-free version available. Maybe it is possible for you to build a launcher executable, that is not linked to the mentioned libraries.

Re: Trine2 on Slackware

Posted: Thu Sep 26, 2013 8:16 am
by FB_JussiE
Hello ZeD and whoami!

We're aware of the issues with the launchers dependencies, and will take a closer look in them in the near future.
Recently we've been very busy with Humble Bundle and what not, but I promise I'll try to get launcher to play nice :)

@ZeD if you can't get the game to work with whoamis instructions let us know and we'll try to help.

Re: Trine2 on Slackware

Posted: Sat Sep 28, 2013 11:32 am
by ZeD
Hi!

I compiled OpenAL and, following whoami suggestion, just "cheated" the launcher copying a couple of generic .so object in the game lib/lib32 directory to match the libselinux and libwrap "dependencies" (btw: I, too, don't get how can you link an unused .so... but I digress)

The game now starts :) Aye!!! :)

*BUT*

Launching the game I cannot see a sprite... it's just a "squared" mashup; a screenshot of what I see is on Image. I tried to play with the settings, but I cannot resolve this different issue.

If it depends on my graphic stack... ATM I'm using an ATI radeon

Code: Select all

[    82.012] (--) RADEON(0): Chipset: "ATI Mobility Radeon HD 5000 Series" (ChipID = 0x68e0)

and I'm using the free radeon drivers, with mesa 9.1.6

Can you help me? Do you need some specific info?

Thanks!

Re: Trine2 on Slackware

Posted: Sat Sep 28, 2013 5:43 pm
by spectatorx
I like the artstyle you achieved! It reminds me NES so much :D

Ok, jokes aside ;-) Did you try amd drivers? I suggest you to use proprietary gpu drivers. Under linux ( in my case ubuntu) i'm using only proprietary drivers and have no problems with games on hd7790.

Re: Trine2 on Slackware

Posted: Mon Oct 28, 2013 3:18 pm
by AnniFB
Did you try the suggestion spectatorx gave? Does the problem still occur?