Trine 2 won't let me play

For discussion about Trine 2, released in December 2011 on Windows, Mac, Xbox, PlayStation Network and later on Linux and Wii U.
Dellysong
Posts: 1
Joined: Sat Apr 21, 2012 12:05 am

Trine 2 won't let me play

Postby Dellysong » Sat Apr 21, 2012 12:09 am

I have had Trine 2 for at least a month and it has worked fine up until today. The launcher comes up and when I click "launch" nothing happens. At most, Steam says I'm online for a few seconds it's like nothing happened. Help please? :(

Thank you.

User avatar
FB_Esa
Posts: 174
Joined: Wed Nov 23, 2011 4:08 pm
Location: Finland
Contact:

Re: Trine 2 won't let me play

Postby FB_Esa » Mon Apr 23, 2012 10:41 am

Hello Dellysong,

Have you tried to verifie your game cache? (right click Trine 2 on menu -> properties -> local content tab -> verifie cache)
If the problem remains it might be a good idea to reinstall the game as i think its a Steam issue.

Hope this helped :)


Return to “Trine 2”

Who is online

Users browsing this forum: No registered users and 4 guests