Game runs really slow

For discussion about Trine 2, released in December 2011 on Windows, Mac, Xbox, PlayStation Network and later on Linux and Wii U.
detachedhead
Posts: 2
Joined: Wed Jul 18, 2012 11:29 am

Game runs really slow

Postby detachedhead » Wed Jul 18, 2012 11:49 am

Guess I'll get my system specs out of the way first
Geforce 550ti graphics card
AMD Athlon 64 X2 Dual Core Processor 5600+ 2.80GHz
6GB RAM
Windows 7 Professional
I tried turning everything off(Anti-aliasing, vertical sync) then setting it to very low. For some reason this makes the game load slower, and doesn't increase playability by tons. If it's set to high/very high it loads up nice and fast but is unplayable.

User avatar
FB_JussiE
Posts: 267
Joined: Wed Nov 23, 2011 4:09 pm
Location: Finland
Contact:

Re: Game runs really slow

Postby FB_JussiE » Wed Jul 18, 2012 12:30 pm

Hello detachedhead

Running the game on very low graphics setting should be used as "last resort", as it indeed increases the loading times a lot.
This is due to the game manually altering the textures when loading.

If the game is playable at low graphics details i'd highly recommend using that instead :)

detachedhead
Posts: 2
Joined: Wed Jul 18, 2012 11:29 am

Re: Game runs really slow

Postby detachedhead » Thu Jul 19, 2012 4:11 am

That does get it running decently. Though still a little slow on the load, but is playable. Thanks

testier
Posts: 2
Joined: Thu Jul 19, 2012 9:06 am

Re: Game runs really slow

Postby testier » Thu Jul 19, 2012 9:07 am

Your CPU is probably bottlenecking you a lot imo.

Borc
Posts: 65
Joined: Mon Dec 19, 2011 8:28 pm

Re: Game runs really slow

Postby Borc » Thu Jul 19, 2012 10:21 am

Very low loads pretty slow but even low loads much slower than high/very high detail settings.

User avatar
Kein
Posts: 169
Joined: Sat Aug 29, 2009 5:34 pm
Location: Soviet Empire
Contact:

Re: Game runs really slow

Postby Kein » Sat Jul 21, 2012 4:46 pm

I don't think CPU is such an issue here, it still shouldn't be that slow. What does FRAPS says, op?

boneitis
Posts: 7
Joined: Sun Jul 22, 2012 9:18 pm

Re: Game runs really slow

Postby boneitis » Sun Jul 22, 2012 9:25 pm

Is there nothing we can do about the loading times? Honestly, they are PAINFULLY slow, and it's not quite the most pleasant thing in the world to have to wait for it every time you want to do anything in the game. The times don't start getting bearable until High detail level on my computer (in fact, my loading time is virtually instantaneous on High and Very High), but the framerate drop is already too much by that point.

User avatar
fb_juha
Posts: 71
Joined: Mon Nov 14, 2005 6:18 pm

Re: Game runs really slow

Postby fb_juha » Mon Jul 23, 2012 1:21 pm

If you want to change only the setting affecting the loading times, you can try the following.

Open %APPDATA%/Trine2/options.txt (you can just copy paste that path to explorer).

Find the following lines and change the values to match these:

setOption(renderingModule, "UseHalfResolutionTextures", false)
setOption(renderingModule, "ColorTextureMipLevelDrop", 0)
setOption(renderingModule, "NormalTextureMipLevelDrop", 0)
setOption(renderingModule, "SpecularTextureMipLevelDrop", 0)

This should make loading times comparable to high detail levels. It will make low settings slightly more expensive for GPU, but it might be worth a try. Please note that these manual changes will be lost every time you change detail levels from launcher.

We are going to fix the actual performance issue, but it might not make it to patch before DLC.

boneitis
Posts: 7
Joined: Sun Jul 22, 2012 9:18 pm

Re: Game runs really slow

Postby boneitis » Tue Jul 24, 2012 6:08 pm

Yes! This is AWESOME!! Thank you.


Return to “Trine 2”

Who is online

Users browsing this forum: Google [Bot] and 8 guests