SG from first person view

All discussion about Shadowgrounds.
Matti
Posts: 135
Joined: Thu Dec 08, 2005 3:43 pm

SG from first person view

Postby Matti » Thu Dec 13, 2007 5:06 pm

It's been talked about before, and now I tell you how to do it. Open file keybinds.txt in directory Shadowgrounds\Profiles\Profile_name\Config and add following line:
camera_first_person_toggle = f1

Now pressing F1 key in the keyboard while playing the game should engage first person view mode.

WARNING WARNING
Free look must be off
Player character and mouse cursor will be invisible
Only primary firing mode works
Mouse X-axis turns aim like in typical FPS games, but Y-axis don't look up/down but instead it moves mouse cursor that is invisible and you'll have no idea does weapon point to floor or roof

This is how it looks like:
Image

[edit]
If someone finds better way to get it work, please TELL ME!

bman654
Posts: 13
Joined: Thu Dec 13, 2007 8:20 pm

Postby bman654 » Thu Dec 13, 2007 8:29 pm

Nice! I've been wondering if this were possible. I'll try it out next time I play.

User avatar
Morrin
Posts: 71
Joined: Tue Jul 25, 2006 5:13 pm
Location: FIN

Postby Morrin » Thu Dec 13, 2007 9:06 pm

Whoa! The screenshot looks amazing... just wow!

User avatar
fb_ilkka
Posts: 14
Joined: Fri Apr 29, 2005 6:51 pm

Postby fb_ilkka » Fri Dec 14, 2007 10:01 am

Hi,

You can get a similar camera angle without entering the fps mode. In the console (f8) enter:

setValue 0;setOptionValue camera_autozoom_enabled
setCameraZoom 0
setCameraBetaAngle 0
setUnitByIdString player1;hideUnit

That should work with both fixed an free camera mode. In free camera mode you can move the mouse to aim vertically. You can also get a nice third-person mode by using something like

setValue 0;setOptionValue camera_autozoom_enabled
setCameraFloatZoom 1.5
setCameraBetaAngle 10
setCameraFOV 90

That seems to work nicely with free camera and survivor's default rotation settings. Tweak the values as you wish.

If your fps starts crawling, you can boost it by limiting visibility:

setCameraRange 80 (or any value that makes it smooth)

With a little work you can make scripts out of these commands so you don't have to type them into the console every time.
// Ilkka, Frozenbyte team

bman654
Posts: 13
Joined: Thu Dec 13, 2007 8:20 pm

Postby bman654 » Sat Dec 15, 2007 12:57 am

If I look at config\user_autoexec.dhps I can see how a script function might look. But where can I put the script so it gets read by the game everytime I start? I'd like to make a script based on your suggestion that I can bind to a key so I can switch from 3rd person over the shoulder mode like you suggest and the normal top-down mode but I don't know where to put the script.

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Postby fb_joel » Sun Dec 16, 2007 10:06 pm

Untested but should work:

Add to Data\Missions\Common\mod_base.dhs/.dhps:

script mod_enablefirstperson
sub main

setValue 0;setOptionValue camera_autozoom_enabled
setCameraZoom 0
setCameraBetaAngle 0
setUnitByIdString player1;hideUnit

endSub
endScript

and then to your mission's sp\startup.dhs/.dhps to sub main: startScriptProcess mod_enablefirstperson

If you want to make a mod that makes SG/SGS first person, then you should add the above line to e.g. mod_base.dhs and its script common_scripted_mission sub begin. Then it should be run every time a mission is loaded.
// Joel, Frozenbyte team

Matti
Posts: 135
Joined: Thu Dec 08, 2005 3:43 pm

Postby Matti » Mon Dec 17, 2007 10:46 pm

Morrin wrote:Whoa! The screenshot looks amazing... just wow!

And some people ask why bother with it :P

Anyways I'm already having my Christmas Holiday at my parents and I couldn't fit my Personal Computer in backpack. It'll be next year when I get back at my PC (this one I'm typing isn't good enough), so I can't try other things out before then. But thanks for Joel! I hope someone else gets to try it and report how it works out.

P.S. Screenshot is taken from last level where several generators needs get blown up. PC (Player Character) is firing Laser Rifle against incoming aliens. That is best weapon to be used with camera_first_person_toggle, since it has nice tracers

ledomira
Posts: 23
Joined: Thu Jun 24, 2010 1:45 am

Re: SG from first person view

Postby ledomira » Sat Feb 23, 2013 9:21 pm

I just got this SG on GOG and I'm enjoying it. I tweaked the camera, but I can't make all the settings stick.

I put the following settings in my user_autoexec.dhs / dhps files.

setValue 0;setOptionValue camera_autozoom_enabled
setCameraBetaAngle 30
setCameraZoom 9


The first two commands stick, but I can't get the setCameraZoom 9 setting to work from that file. I have to manually enter it in to the console every time I play. Also, every time there is a checkpoint or a cutscene, it resets the zoom and I have to re-enter it.

I tried binding it to a key, but it won't work. The command to bind is: bind pause,p (I'm just using pause as an example), but it doesn't seem to work with commands that use variables.

How do I bind a command that defines a variable to a key? I tried commands like these, but they don't work:
bind setCameraZoom 9, q
bind "setCameraZoom 9",q
bind (setCameraZoom 9),q
and several others

I made sure to use unbind q before to avoid any potential conflicts.


I can't find an example of how to do that in any of the config files. How do I bind that command to the key of my choice? If possible, can I bind multiple commands to one key?

I tried following the directions to make my own script in a mod, but I couldn't get the game to work when I did that. I'm just looking for the quickest solution that doesn't require the console every time I play.

opelhatza
Posts: 2
Joined: Thu Feb 27, 2014 2:50 am

Re: SG from first person view

Postby opelhatza » Thu Feb 27, 2014 2:55 am

Sorry for reviving such an old thread. I just buyed on steam shadowgrounds and survivor but dont like the Camera Perspective.
So i tryed the console commands:
setValue 0;setOptionValue camera_autozoom_enabled
setCameraZoom 0
setCameraBetaAngle 0
setUnitByIdString player1;hideUnit

But i can not type the underlines _ in the console. So what can i do?

Sorry for my bad english

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: SG from first person view

Postby MarjutFB » Wed Mar 05, 2014 11:24 am

opelhatza wrote:Sorry for reviving such an old thread. I just buyed on steam shadowgrounds and survivor but dont like the Camera Perspective.
So i tryed the console commands:
setValue 0;setOptionValue camera_autozoom_enabled
setCameraZoom 0
setCameraBetaAngle 0
setUnitByIdString player1;hideUnit

But i can not type the underlines _ in the console. So what can i do?

Sorry for my bad english


Hi opelhatza,

The problem could be with the language of your operating system or keyboard. If your keyboard is in another language then English (US) specific characters might not work. As a result you can't type the underline in game by pressing the keys you usually would as the possible key or key combination is something else instead.

So, it's worth a try to change the language of your keyboard to English which matchs to the game. You can also look for the possible key to do this with your keyboard language.

If this didn't help could you tell what operating system you're using and in what language your system and keyboard are? Your keyboard is usually in the same language as your system. The language of your keyboard can be found through Windows Settings, or is often readable from your start bar (on the right side).

Also what kind of keyboard do have in use?

Let me know how it goes!

opelhatza
Posts: 2
Joined: Thu Feb 27, 2014 2:50 am

Re: SG from first person view

Postby opelhatza » Thu Dec 25, 2014 12:14 am

Hi opelhatza,

The problem could be with the language of your operating system or keyboard. If your keyboard is in another language then English (US) specific characters might not work. As a result you can't type the underline in game by pressing the keys you usually would as the possible key or key combination is something else instead.

So, it's worth a try to change the language of your keyboard to English which matchs to the game. You can also look for the possible key to do this with your keyboard language.

If this didn't help could you tell what operating system you're using and in what language your system and keyboard are? Your keyboard is usually in the same language as your system. The language of your keyboard can be found through Windows Settings, or is often readable from your start bar (on the right side).

Also what kind of keyboard do have in use?

Let me know how it goes!


Sorry for the late answer.....

With the language change it works i changed my os and the keybord layout for german to english and now everything works fine. Just tryed it today so thanks now i can type the _. Thx for the help.


Return to “Shadowgrounds”

Who is online

Users browsing this forum: No registered users and 4 guests