Cannot install in Ubuntu 14.04

All discussion about Shadowgrounds.
Kirov123
Posts: 1
Joined: Tue Sep 16, 2014 3:04 am

Cannot install in Ubuntu 14.04

Postby Kirov123 » Tue Sep 16, 2014 3:09 am

Whenever I attempt to install the game, my terminal returns the error :
./shadowgroundsUpdate1.run: error while loading shared libraries: libglade-2.0.so.0: cannot open shared object file: No such file or directory
My searches for a solution have been fruitless. Can anyone here help me out?

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: Cannot install in Ubuntu 14.04

Postby MarjutFB » Tue Sep 16, 2014 11:57 am

Do you have the Humble Store version of the game?

You could try opening the terminal and typing in

Code: Select all

sudo apt-get install libglade2-0:i386

Entering the command should install the missing library and then allow you to launch the installer.

Let me know how it goes!

UrbanFlash
Posts: 3
Joined: Sun Sep 21, 2014 1:52 am

Re: Cannot install in Ubuntu 14.04

Postby UrbanFlash » Sun Sep 21, 2014 1:55 am

I had the same problem and fixed it like you suggested, now i get:

Code: Select all

~/games/shadowgrounds$ ./shadowgrounds-launcher
./shadowgrounds-launcher: ./lib32/libxml2.so.2: no version information available (required by /usr/lib/i386-linux-gnu/libglade-2.0.so.0)
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
./shadowgrounds-launcher: symbol lookup error: /usr/lib/i386-linux-gnu/libXrandr.so.2: undefined symbol: _XGetRequest
~/games/shadowgrounds$


Any idea how i can fix this?

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: Cannot install in Ubuntu 14.04

Postby MarjutFB » Wed Sep 24, 2014 9:14 am

UrbanFlash wrote:I had the same problem and fixed it like you suggested, now i get:

Code: Select all

~/games/shadowgrounds$ ./shadowgrounds-launcher
./shadowgrounds-launcher: ./lib32/libxml2.so.2: no version information available (required by /usr/lib/i386-linux-gnu/libglade-2.0.so.0)
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
./shadowgrounds-launcher: symbol lookup error: /usr/lib/i386-linux-gnu/libXrandr.so.2: undefined symbol: _XGetRequest
~/games/shadowgrounds$


Any idea how i can fix this?


Following the instructions below should fix the loading error.

  1. Navigate to the location of the game folder.
  2. Copy paste the following command:

    Code: Select all

    mkdir ./lib32_old && mv ./lib32/{libX11.so.6,libXau.so.6,libXcomposite.so.1,libXcursor.so.1,libXdamage.so.1,libXdmcp.so.6,libXext.so.6,libXfixes.so.3,libXi.so.6,libXinerama.so.1,libXmu.so.6,libXrender.so.1,libXt.so.6,libm.so.6,libopenal.so.1,libstdc++.so.6,libvorbis.so.0,libvorbisfile.so.3,libxcb-render.so.0,libxcb-render-util.so.0,libxcb-xlib.so.0,libxcb.so.1,libz.so.1} ./lib32_old

  3. Now try to launch the game, if there are any issues about missing libraries, copy the needed libraries from the lib32_old directory to the new one and then try again.

Let me know if you have any questions about this, or just how it goes. Cheers!

UrbanFlash
Posts: 3
Joined: Sun Sep 21, 2014 1:52 am

Re: Cannot install in Ubuntu 14.04

Postby UrbanFlash » Wed Sep 24, 2014 1:02 pm

Hello and thanks for the reply. I ran your command and tried to start the game, but it still doesn't work. I now get the following output. There was no clear message of a lib missing, apart from the first line, which is identical to before.


Code: Select all

~/games/shadowgrounds$ ./shadowgrounds-launcher
./shadowgrounds-launcher: ./lib32/libxml2.so.2: no version information available (required by /usr/lib/i386-linux-gnu/libglade-2.0.so.0)
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(shadowgrounds-launcher:30267): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Gtk-Message: Failed to load module "canberra-gtk-module"
Segmentation fault (core dumped)
~/games/shadowgrounds$

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: Cannot install in Ubuntu 14.04

Postby MarjutFB » Thu Sep 25, 2014 2:44 pm

UrbanFlash wrote:Hello and thanks for the reply. I ran your command and tried to start the game, but it still doesn't work. I now get the following output. There was no clear message of a lib missing, apart from the first line, which is identical to before.


Apparently you might have to try to launch the game multiple times. Could you try this?

You could also try to launch the game directly instead - not the game's launcher. If you can't open the launcher, you have to set the correct resolution and other settings through the game's options.txt file. Let me know if you need any help with this.

Hopefully you can get it to work now. Let me know how it goes.

Cheers!

UrbanFlash
Posts: 3
Joined: Sun Sep 21, 2014 1:52 am

Re: Cannot install in Ubuntu 14.04

Postby UrbanFlash » Thu Sep 25, 2014 4:40 pm

I tried launching multiple times already, that didn't change anything.

Launching the shadowgrounds-bin helped though, after moving libXmu.so.6 and libvorbisfile.so.3 back to the lib32 folder i can now play the game.

Sound is still wonky at some times and it doesn't seem to respect the resolution i set in the options.txt, but at least i can play the game.

Thank you for your support, i really appreciate it.

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: Cannot install in Ubuntu 14.04

Postby MarjutFB » Fri Sep 26, 2014 1:38 pm

UrbanFlash wrote:I tried launching multiple times already, that didn't change anything.

Launching the shadowgrounds-bin helped though, after moving libXmu.so.6 and libvorbisfile.so.3 back to the lib32 folder i can now play the game.

Sound is still wonky at some times and it doesn't seem to respect the resolution i set in the options.txt, but at least i can play the game.

Thank you for your support, i really appreciate it.


I forgot to mention that right options.txt is located at

Code: Select all

home/.frozenbyte/shadowgrounds/config


If the options.txt file is missing for some reason, you can copy the default one from the game's folder. Which would be the following:

Code: Select all

/home/shadowgrounds/config/


But good that the game is running now. There unfortunately has been some issues with sounds, but hopefully it won't effect your experience too much.

Let me know if you have any questions about this. Otherwise I hope you have fun playing! :)


Return to “Shadowgrounds”

Who is online

Users browsing this forum: No registered users and 1 guest