Endgame Cinematic glitch [spoilers, technically, I guess]

All discussion about Shadowgrounds.
xolotl
Posts: 24
Joined: Tue Apr 12, 2011 11:41 pm

Endgame Cinematic glitch [spoilers, technically, I guess]

Postby xolotl » Thu Apr 28, 2011 11:18 pm

Figured I may as well report this as well... I'm using the Linux build (from the Bundle), running at 1024x768, and it appears that a couple of the cinematics "repeat" on the screen, rather than staying letterboxed like they should. For instance, the cinematic background on the main menu looks like this (resized a bit) :
opening.png
You can see some stuff that shouldn't be there on the very bottom of the screen.

It becomes much more pronounced on the first of the two endgame cinematics, where it's repeated both above and below where it should be (again, resized a bit) :
cinematic6.png
The subtitles are showing up where they should, but they're on top of the repeated movie, rather than on blackness.

Interestingly, the second cinematic in the endgame does not do that, and I don't remember any other cinematic in the game exhibiting that behavior, though I don't recall how many there were. The opening cinematic does work properly, at least.

And then unrelatedly, because I don't think it really merits its own topic, I did notice this glitch related to the flashlight, on the last level:
pattern.png

As you can see, my character's shining his flashlight at a solid wall, but a pattern of light is being cast on the far side. Not a big deal, of course, just figured that since the sourcecode's out there now, it's possible a new build could surface which'd fix that. :)

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: Endgame Cinematic glitch [spoilers, technically, I guess

Postby fb_joel » Thu May 05, 2011 5:43 pm

Oh, I had thought it was related to widescreen issues but apparently not. This should only happen on the Linux version (and possibly Mac) - it might be related to videos somehow, because the main menu game logo is actually a video, and so are the introduction cutscene and the end cutscenes (the ending has at least two videos, and a few ingame cutscenes combined). Not quite sure why it didn't happen on the introduction one then though... We're looking into this a little bit, although I'm not sure if a fix is imminent.

The second one is probably a small issue with the building model, I have a vague memory of the original Windows version also exhibiting this behavior... Not going to fix because it would probably require touching the behemoth mothership object model and that's scary. :)
// Joel, Frozenbyte team

mykro76
Posts: 3
Joined: Thu Apr 14, 2011 9:56 am

Re: Endgame Cinematic glitch [spoilers, technically, I guess

Postby mykro76 » Mon May 09, 2011 8:27 am

Just adding that I saw the same endgame cutscene letterbox glitch at 1920x1080 fullscreen on Ubuntu 10.10, proprietary NVIDIA driver. Wasn't as pronounced as xolotl's, as at this resolution the top and bottom "glitchy bars" are only about 50 pixels high. Does look a bit odd though.


Return to “Shadowgrounds”

Who is online

Users browsing this forum: No registered users and 3 guests