Constant game freezing

All discussion about Shadowgrounds.
pielgrzym
Posts: 2
Joined: Tue Oct 04, 2011 12:25 am

Constant game freezing

Postby pielgrzym » Sun Oct 09, 2011 7:42 pm

Hi,

Disclaimer: I'm fully aware that my hardware is faulty here, I'm just trying to track down what could possibly be dead.

I've got nvidia 9500GT from Zotac with dual-head setup. I experience freezes in 3d games all along - after a couple of minutes the game stops, Xorg.0.log shows that Nvidia waits. After shorter (couple secs) or usually longer (up to a minute) period the game resumes. I've managed to finish Trine twice with those freezes. Now I know it's not linux issue since running Trine from windows on second hd gives me exactly same freezes. I've ruled out two things: heat - card doesn't go above 65-68 degrees celsius during play and ram (or all my ram is broken, could be). Now, to the point: when I try to run shadowgrounds with normal details there is a constant freeze with a 1-2s of normal play and another and another. When I lower all the details to the minimum level shadowgrounds still freezes I can move the hero around for 5-10 seconds. I've noticed that disabling anisotrophic filtering made trine run less freezy, this doesn't help with shadowgrounds. Any tips? Perhaps a magic-mystery setting in options.txt? After enabling some logs I get log (400kb after 1 minute of freezing) full of messages:

WARNING: ObjectDurabilityParser::getDurabilityTypeIndexByName - Given durability type name name not found.
ERROR: Storm3D::CreateNewTexture - File does not exist or is zero length.

Any ideas?

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: Constant game freezing

Postby fb_joel » Tue Oct 11, 2011 8:18 pm

Well, there probably isn't any magic settings that will help... You could however try to run in e.g. Windowed mode, or perhaps disabling sounds. And in general trying the lowest graphics options might be worth a shot too.

You could also disable physics I believe (at least for the SG games), they're there in the config/options.txt file. Trine probably won't work at all if physics aren't used.

Even if it's not a heat problem, sometimes it helps to limit the framerate. You can open the game console terminal with F8 button (or F6 in Linux I think), and write:

/show_fps 1
/render_max_fps 30

This should show it and limit to 30. Might give a bit more time before freezes...

Usually these kind of problems are either caused by the graphics card, memory or the PSU. If you have any old PSUs lying around, that would be my next step.

There's also a rather detailed thread here that can offer some additional tips, as the reasons for reboots/freezes etc are usually similar...
// Joel, Frozenbyte team

alt_turo
Posts: 195
Joined: Mon Dec 13, 2010 11:06 am

Re: Constant game freezing

Postby alt_turo » Wed Oct 12, 2011 11:44 am

pielgrzym wrote:Hi,
I've got nvidia 9500GT from Zotac with dual-head setup. I experience freezes in 3d games all along - after a couple of minutes the game stops, Xorg.0.log shows that Nvidia waits. After shorter (couple secs) or usually longer (up to a minute) period the game resumes. I've managed to finish Trine twice with those freezes. Now I know it's not linux issue since running Trine from windows on second hd gives me exactly same freezes. I've ruled out two things: heat - card doesn't go above 65-68 degrees celsius during play and ram (or all my ram is broken, could be). Now, to the point: when I try to run shadowgrounds with normal details there is a constant freeze with a 1-2s of normal play and another and another. When I lower all the details to the minimum level shadowgrounds still freezes I can move the hero around for 5-10 seconds. I've noticed that disabling anisotrophic filtering made trine run less freezy, this doesn't help with shadowgrounds. Any tips? Perhaps a magic-mystery setting in options.txt?

You're probably out of graphics memory and the driver starts swapping things between GPU and main memory. There are at least two version of this card, 512MB and 1GB versions. Which one do you have?

You can try:
1. Disable dual-head. This will free memory used by the other monitor.

2. Disable desktop compositing. This will save memory on the GPU. Playing in fullscreen mode should also do this. Maybe.

3. Reduce resolution

4. On Shadowgrounds and Survivor but not Trine, set detail level to very low. Or under advanced settings, change shadows and texture levels to very low. This will use smaller textures/shadow maps.


WARNING: ObjectDurabilityParser::getDurabilityTypeIndexByName - Given durability type name name not found.
ERROR: Storm3D::CreateNewTexture - File does not exist or is zero length.

These are normal. Some of the data references unnecessary files which were left out and results in nasty messages but nothing else.
Turo Lamminen
Alternative Games


Return to “Shadowgrounds”

Who is online

Users browsing this forum: No registered users and 3 guests