Page 1 of 1

[SOLVED] Trine 2 not working on Intel HD Graphics 2000

Posted: Fri Mar 29, 2013 10:18 pm
by alemartini
Hi,

I'm trying to run Trine 2 on Linux, but so far it's not working. While the game is loading, the screen is completely black (the "Trine 2" and "Frozenbyte" splashs don't show up), and after that you can only see some dark polygons as the background for the main menu. The menu text is rendered fine (I can read it and navigate through it).

When I start a new game, it only shows lots of oddly shaped polygons.

Here are the details of the OS and hardware on which I'm trying to run the game:

OS: Debian Wheezy (i386)
DE: Xfce 4.8.3
CPU: Core i3-2120T
Memory: 4 GB
Video: Intel HD Graphics 2000. lspci -nn shows the following:

Code: Select all

Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)


Is there any way to get Trine 2 running properly on Linux with this hardware?


Thanks in advance,
Alex

Re: [SOLVED] Trine 2 not working on Intel HD Graphics 2000

Posted: Sat Apr 06, 2013 6:13 am
by alemartini
Oh well, nevermind... 8)

@FrozenByte: you should really put more care in documenting what extra packages might be needed to get the game running properly (and not to mention answering the questions posted by paying customers in a timely manner). I think that those of us using "alternative" operating systems (not Windows) deserve at least that.

Re: [SOLVED] Trine 2 not working on Intel HD Graphics 2000

Posted: Mon Apr 08, 2013 7:12 am
by fb_jlarja
alemartini wrote:Oh well, nevermind... 8)

@FrozenByte: you should really put more care in documenting what extra packages might be needed to get the game running properly (and not to mention answering the questions posted by paying customers in a timely manner). I think that those of us using "alternative" operating systems (not Windows) deserve at least that.


Sorry for the silence :oops: . The thing is, I don't think we have a single active (desktop) Linux gamer working for the company (I do use Linux daily and keep our servers running, but that doesn't really help in supporting Trine on Linux).

(And I'm not really a support person. Just making suggestions :) .)

We don't withhold information on purpose, so if you could explain what you needed to do to get the game to run (or at least start, I read your other post about performance problems) on Wheezy, we would appreciate that (and add the information to FAQ / Readme / installation instructions). Currently, I don't think Debian is part of our (quite limited) Linux testing suite.

-JLarja