Trine 2 does not launch (Mac OS X Mavericks)

Technical support for the Linux and Mac platforms for all Trine games.
mpo999
Posts: 2
Joined: Mon Jan 06, 2014 7:31 am

Trine 2 does not launch (Mac OS X Mavericks)

Postby mpo999 » Mon Jan 06, 2014 7:44 am

Hi,

After the latest patch was released in November, I have not been able to play Trine 2 because the game does not launch.

Once I click "Start Trine 2" a blank window appears and then the screen goes blank. My system is frozen and I have to do a hard restart.

I am playing on a 2012 MacBook Pro that is running OS X 10.9.1 (Mavericks):
Processor 2.6 GHz Intel Core i7
Memory 8 GB 1600 MHz DDR3
Graphics Intel HD Graphics 4000 1024 MB

I verified the integrity of the game cache through Steam, and there were no issues.

Reading the forums, I noticed that some PC gamers were having problems launching Trine 2 after the patch and that a workaround was discovered

Have you found a workaround for Mac users with the same issue?

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: Trine 2 does not launch (Mac OS X Mavericks)

Postby MarjutFB » Fri Feb 07, 2014 11:29 am

Hi mpo999,

Sorry for the delay.

Is the problem still occuring?

If it is you could try to turn off "Enable Steam Community In-Game" (you can do this through Steam's settings) and try if you can launch the game then. If that doesn't work then you could try the following (you have to have an administrator account to do this):

Open up System Preferences
Click Security & Privacy
Click the Lock to make changes
Check that 'Steam.app' is selected on Accessibility tab
Relog to your current user
Run Trine 2

If you are still seeing the black screen could you tell what applications you are running while starting the game? Are you trying to run the game on an administrator account?

Let me know how it goes!

mpo999
Posts: 2
Joined: Mon Jan 06, 2014 7:31 am

Re: Trine 2 does not launch (Mac OS X Mavericks)

Postby mpo999 » Sat Feb 08, 2014 11:56 pm

Hi,

Thanks for getting back to me!

I had previously granted Steam access to the accessibility functionality in System preferences.

I tried disabling Steam Community In Game but that did not help.

I typically run the game from an administrator account. I did create a standard user account on my mac, redownload the game to that account, and the tried to launch it. Again, as soon as I click "Start Trine 2," I a blank window appears and then the screen goes blank. My system is frozen and I have to do a hard restart.

On the standard user account, I did not have any other apps running aside from Finder and Steam.

On the admin account, I had following running in the background when I tried to launch Trine 2:

- TotalFinder
- my company's VPN client (but VPN is turned off)

There are probably other apps and processes in the background, but nothing explicitly running.

Do you need me to run a particular log? If so, please let me know how to do that.

thanks


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 4 guests