Problems with Trine on 2010 15" Macbook Pro

Technical support for the Linux and Mac platforms for all Trine games.
jkquiles
Posts: 1
Joined: Wed Apr 13, 2011 1:41 pm

Problems with Trine on 2010 15" Macbook Pro

Postby jkquiles » Wed Apr 13, 2011 1:52 pm

I'm having problems running Trine well on my 2010 Macbook Pro 15 inch. Originially when I ran the game with all the highest settings, it want well then suddenly the framerate dropped to a crawl. I've been experimenting with different settings and this morning I managed to get through the first scene with the thief running at 60fps, then suddenly it dropped to 23. From the requirements page, I feel that there is no reason why my computer shouldn't be able to run this game decently at fairly high settings (2.6Ghz i7 Dual Core, GeForce 330M 512MB, 4GB RAM). Please advise.

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: Problems with Trine on 2010 15" Macbook Pro

Postby fb_joel » Fri Apr 15, 2011 7:37 pm

This is interesting - I think we have one other user who is experiencing serious framerate drops on a Mac, but in his case we're talking about a slideshow, something like 5-10 frames per second at times.

In this case it could be "normal" - Trine does have a variety of places and levels and some might require a bit more power than others.

I agree your Mac should be able to run the game at a reasonably high setting. It might be worth double-checking that any antialiasing is turned off (or at most 2x) because antialiasing causes a big performance hit. Other than that, it's just lowering the resolution and turning the settings down a notch. I think that will help enough and still keep the game beautiful.

I hope this helps! (And sorry for the delay.)
// Joel, Frozenbyte team


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 2 guests