Linux: 64 bit Ubuntu trine aborts before Running

Technical support for the Linux and Mac platforms for all Trine games.
dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Fri Apr 15, 2011 2:20 am

Laptop:~/Programs/trine$ ./trine-bin64
Got signal 11 at (nil) from (nil)
./trine-bin64[0x433c98]
/lib/libc.so.6(+0x33c20)[0x7fc99aa99c20]
Aborted



:~/Programs/trine$ ./trine-bin32
Got signal 11 at (nil) from (nil)
./trine-bin32[0x8078188]
[0xf777b410]
Aborted

Just in case, I have a GTX260, 1 gig, nvidia binaries installed.

philh
Posts: 14
Joined: Fri Apr 15, 2011 1:54 am

Re: 64 bit Ubuntu trine aborts before Running

Postby philh » Fri Apr 15, 2011 3:20 am

Which Ubuntu version are you using? it seems to run ok on 10.10 amd64 for me.
I take it you've tried running from the launcher and that failed too?

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Fri Apr 15, 2011 4:36 pm

10.10 64bit. Yes if from Launcher is same exact error.

Brian
Posts: 8
Joined: Wed Apr 13, 2011 7:53 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby Brian » Sat Apr 16, 2011 12:30 am

I had the exact same exit signal.

padsp ./trine-launcher fixed it for me.

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sat Apr 16, 2011 1:48 am

Brian wrote:I had the exact same exit signal.

padsp ./trine-launcher fixed it for me.


Not me:

Laptop:~/Programs/trine$ padsp ./trine-launcher
Got signal 11 at (nil) from (nil)
./trine-bin64[0x433c98]
/lib/libc.so.6(+0x33c20)[0x7fd37b64cc20]
Aborted

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sat Apr 16, 2011 2:22 am

Just installed the latest Nvidia binary drivers 260.44 same errors.

allquixotic
Posts: 11
Joined: Mon Nov 26, 2007 2:08 am
Location: Nospamland, NS
Contact:

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby allquixotic » Sat Apr 16, 2011 2:26 am

If you have the same problem as me, you need to either enable sound or disable video.

Here's a mail I got from Turo, in response to my query containing a stack trace:

> $ ./trine-bin64
> Got signal 11 at (nil) from 0x57340a
> ./trine-bin64[0x433c98]
> /lib64/libpthread.so.0[0x341820f3c0]
> ./trine-bin64[0x57340a]
> ./trine-bin64[0x573ccc]
> ./trine-bin64[0x543a26]
> ./trine-bin64[0x78dc22]
> /lib64/libc.so.6(__libc_start_main+0xed)[0x3417e2143d]
> ./trine-bin64(_ZNSt8ios_base4InitD1Ev+0x49)[0x40bd19]
> Aborted (core dumped)
This looks like an audio problem. Do you have sounds disabled? There is
a known bug where videos crash if sound is disabled. You can try
changing video_enabled to 0 in
~/.frozenbyte/trine/config/options.txt


So our stack traces aren't identical, but it's possible you may have the same problem. Of particular interest is that the hexadecimal address of the crashing function (at the top of the stack) for trine-bin64 is identical between our two stack traces:

./trine-bin64[0x433c98]

So just enable sound in the launcher's configuration, or disable video like Turo instructs. :)

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sat Apr 16, 2011 2:38 am

I tried both disabling video, enabling/disabling sound, same error. How do i run a stack trace?

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sat Apr 16, 2011 2:49 am

Also mine has:

/lib/libc.so.6(+0x33c20)[0x7f4df63e2c20]


And, all 3 games don't work. I'm just like frustrated at this point.

thenewguy
Posts: 33
Joined: Sat Sep 18, 2010 11:58 pm

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby thenewguy » Sat Apr 16, 2011 6:07 pm

What type of video card do you have? I tried running Trine on two very similar systems, one with an nVidia card and one with an onboard Intel card. I got the crash mentioned above on the Intel machine, but everything worked on the nVidia box.

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby fb_joel » Sat Apr 16, 2011 7:03 pm

One additional thing to try is to enable sounds and also enable EAX. This apparently has helped one user on the Windows side (for some unfathomable reason).

Also, it might be good to try older NVIDIA drivers. Who knows.

I'm sorry for the trouble, seems like we've hit some rare point in the game with this system. :(
// Joel, Frozenbyte team

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sun Apr 17, 2011 1:50 am

fb_joel wrote:One additional thing to try is to enable sounds and also enable EAX. This apparently has helped one user on the Windows side (for some unfathomable reason).

Also, it might be good to try older NVIDIA drivers. Who knows.

I'm sorry for the trouble, seems like we've hit some rare point in the game with this system. :(



No eax option in the launchers, set it in the .frozenbyte/trine/config/options.txt however, still no change.

Will try the oldest NVIDIA drivers I can.

How do I do a stack trace tho?

EDIT: Older nvidia drivers don't work, I also Can't go farther back then 256.*, they changed how they did drivers, and the earlier versions won't install. I created a new profile and it does same thing. SO somewhere in the system it's not working.

mkevac
Posts: 4
Joined: Sun Apr 17, 2011 10:24 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby mkevac » Sun Apr 17, 2011 10:25 am

Same error on my Ubuntu 10.10 64 bit

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sun Apr 17, 2011 3:40 pm

mkevac wrote:Same error on my Ubuntu 10.10 64 bit



WHat graphics card do you have? Cause I feel like I'm the only one with a nvidia card that it doesn't work.

steeliuzzz
Posts: 1
Joined: Sun Apr 17, 2011 3:58 pm

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby steeliuzzz » Sun Apr 17, 2011 4:05 pm

Hello!

I bought the bundle too. Neither of the games is running.
I tried it under Ubuntu 10.10 /11.04 64bit.
WIth intel-graphics and hybrid-nvidia-graphics. Several hours of my life since then.

I am very disappointed - I was a strong supporter of your "bundle"-campagne until then.
I think issueing out "linux" games that require proprietary nvidia/ati drivers is absolutely not the way.

In my view the whole campaign has lessened the standing of OpenSourceOS-ideas and i will never again support such unripe beta-experiments.

mkevac
Posts: 4
Joined: Sun Apr 17, 2011 10:24 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby mkevac » Sun Apr 17, 2011 4:37 pm

dardack wrote:WHat graphics card do you have? Cause I feel like I'm the only one with a nvidia card that it doesn't work.


GeForce 9800 GTX+
With open source driver, not nVidia one.

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sun Apr 17, 2011 4:39 pm

mkevac wrote:
dardack wrote:WHat graphics card do you have? Cause I feel like I'm the only one with a nvidia card that it doesn't work.


GeForce 9800 GTX+
With open source driver, not nVidia one.


Huh, tried the binary one?

mkevac
Posts: 4
Joined: Sun Apr 17, 2011 10:24 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby mkevac » Sun Apr 17, 2011 5:17 pm

dardack wrote:Huh, tried the binary one?

Yes. It works with binary driver.

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Sun Apr 17, 2011 5:27 pm

mkevac wrote:
dardack wrote:Huh, tried the binary one?

Yes. It works with binary driver.



Well damn it why doesn't it work for me.

EDIT: What version of the binary are you using?

mkevac
Posts: 4
Joined: Sun Apr 17, 2011 10:24 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby mkevac » Sun Apr 17, 2011 6:13 pm

dardack wrote:EDIT: What version of the binary are you using?


One, that is in Ubuntu 10.10: 260.19.06

allquixotic
Posts: 11
Joined: Mon Nov 26, 2007 2:08 am
Location: Nospamland, NS
Contact:

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby allquixotic » Mon Apr 18, 2011 1:26 am

steeliuzzz wrote:Hello!

I bought the bundle too. Neither of the games is running.
I tried it under Ubuntu 10.10 /11.04 64bit.
WIth intel-graphics and hybrid-nvidia-graphics. Several hours of my life since then.

I am very disappointed - I was a strong supporter of your "bundle"-campagne until then.
I think issueing out "linux" games that require proprietary nvidia/ati drivers is absolutely not the way.


It doesn't require proprietary drivers, it just requires the patented S3TC texture compression support. I posted a long how-to and explanation in another thread on these forums.

steeliuzzz wrote:In my view the whole campaign has lessened the standing of OpenSourceOS-ideas and i will never again support such unripe beta-experiments.


The game has several fans among the graphics developer / enthusiast programmer community. If they would release Trine's source code under an open license as part of the Humble Bundle deal, then these enthusiasts would probably patch the game to improve performance on the open source graphics stack. Certainly there are ways to only use functions that we know perform well with Mesa -- or, alternatively, figure out why the current Trine code is performing slowly, and help optimize Mesa to run it faster. But this becomes way easier if we have the Trine source.

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Mon Apr 18, 2011 1:41 am

OMG Finally got it working natively.

Had to reinstall Ubuntu, something musta messed up my system somewhere. But everything reinstalled and game runs now. So happy (btw all 3 run now).

http://dardack.is-a-geek.org/trine_ss_NativeLinux.jpg

http://dardack.is-a-geek.org/trine_ss_wine.jpg

Same settings, so wish the OpenGL calls were better in native. Since the wine look sbetter, but has little glitches here and there (and esp mouse glitches on Surv/Shadow).

Xpander
Posts: 34
Joined: Fri Apr 15, 2011 5:40 am
Location: Estonia

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby Xpander » Mon Apr 18, 2011 1:56 am

try viewtopic.php?p=13970#p13970

for the blurry native version fix.
looks much better after this
Linux Mint 13 alpha 64bit
* AMD Phenom II x4 955 BE (3,2 ghz)
* 8GB ddr3 1600mhz
* Asus GTX 560Ti DirectCU

dardack
Posts: 22
Joined: Fri Apr 15, 2011 2:17 am

Re: Linux: 64 bit Ubuntu trine aborts before Running

Postby dardack » Mon Apr 18, 2011 3:04 am

Xpander wrote:try viewtopic.php?p=13970#p13970

for the blurry native version fix.
looks much better after this



Damn your right. Hope more graphical improvements are on the way. That post tho from the FB person needs to like specify line numbers/file to edit, took me a while to get it right.

Also, i just realized it wasn't saving games, so got that fixed, sigh 1hr of progress down the tubes.


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 14 guests