OpenGL 2.0 required on Radeon HD5870 ?

Technical support for the Linux and Mac platforms for all Trine games.
adrenochrome
Posts: 3
Joined: Fri Sep 30, 2011 6:54 pm

OpenGL 2.0 required on Radeon HD5870 ?

Postby adrenochrome » Fri Sep 30, 2011 7:06 pm

Hello,

I'm trying to run Trine (64bit version) from humble bundle on an ubuntu 11.04

I can see the launcher, but when trying to start the game i get a popup saying "renderer initialization failure"
the log only report :
30.9.2011 [17:51]
ERROR: OpenGL 2.0 required
ERROR: Your graphics card cannot run this game. You can try updating your drivers.

i have a radeon 5870 with fglrx (8.892) drivers, so opengl 4.1

i tried to remove libstdc++ from lib64 as suggested here
the only difference is that now i can see a black screen for a fraction of second, but still the same error messages

any idea ?
Last edited by adrenochrome on Sun Oct 02, 2011 5:46 pm, edited 3 times in total.

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: ERROR: OpenGL 2.0 required

Postby fb_joel » Sat Oct 01, 2011 9:59 pm

Should run hardware-wise I suppose, so the problem is most likely on the driver side... Have you checked the Linux FAQ (not very extensive I know, and I guess you have indeed read that)? You could try other drivers (even older ones, who knows), perhaps even the Gallium ones... Probably available from System > Admin > Additional Drivers.

Not really much else I can say as I'm a Linux newbie myself... Do the Shadowgrounds games run ok?
// Joel, Frozenbyte team

User avatar
Urfoex
Posts: 50
Joined: Fri Apr 15, 2011 11:14 am

Re: ERROR: OpenGL 2.0 required

Postby Urfoex » Sun Oct 02, 2011 11:58 am

A little bit more info would be nice.
Something like:

Code: Select all

glxinfo

Code: Select all

fglrxinfo

Code: Select all

ldd ./trine-bin64


Does the following commands work and give no failures or errors?

Code: Select all

glxgears

Code: Select all

fgl_glxgears

Code: Select all

amdcccle
+-----------------------------------------------------------------\
| Debian testing 64Bit on
| * AMD Phenom x4 905e (4x2500Mhz)
| * 6GB Ram
| * AMD/ATI Radeon HD4770 (fglrx)
+-----------------------------------------------------------------/

adrenochrome
Posts: 3
Joined: Fri Sep 30, 2011 6:54 pm

Re: ERROR: OpenGL 2.0 required

Postby adrenochrome » Sun Oct 02, 2011 5:03 pm

hello,


thanks for your answers

about the drivers i'm using the proprietary one from AMD and they are supposed to be more advanced than the opensource one (gallium).
I dont plane to downgrade to gallium for now.

No way to run shadowgrounds 32bit binaries : to much dependencies problems
I struggled a lot to compile shadowgrounds engine, but i didnt ty to launch it yet. I guess that i'll be able to run shadowgrounds or to find the version string that i suspect to be misinterpreted. I hope that this feed back will help you to fix trine engine.

about shadowgrounds source code, the archive provided by humblebundle dont seems to include any makefile-like system for linux(no install or readme found :/ ), i hade to use the sources from here : https://github.com/vayerx/shadowgrounds :/
what's the difference with these sources : http://code.google.com/p/shadogrounds-a ... -survivor/ ?
which of the 3 versions (bundle,googlecode,github) is the most uptodate and the most official ?


of course opengl work perfectly on my system with everything i tested (except trine)
glxgears, fgl_glxgears, amd settings, modern games native or through wine ....

i checked the faq and other threads from the forum, everything seems to be ok :
GL_EXT_texture_compression_s3tc is available
GL_ARB_framebuffer_object too
libGLEW is in v1.5.7

here are the outputs of the commands :
fglrxinfo
glxinfo
ldd trine-bin64

User avatar
Urfoex
Posts: 50
Joined: Fri Apr 15, 2011 11:14 am

Re: OpenGL 2.0 required on Radeon HD5870 ?

Postby Urfoex » Sun Oct 02, 2011 9:42 pm

Looking inside your glxinfo, saying:

Code: Select all

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)


That means, that your driver isn't installed properly.

Try to reinstall it .
Also try the one from the AMD website if the other way doesn't work.
+-----------------------------------------------------------------\
| Debian testing 64Bit on
| * AMD Phenom x4 905e (4x2500Mhz)
| * 6GB Ram
| * AMD/ATI Radeon HD4770 (fglrx)
+-----------------------------------------------------------------/

adrenochrome
Posts: 3
Joined: Fri Sep 30, 2011 6:54 pm

Re: OpenGL 2.0 required on Radeon HD5870 ?

Postby adrenochrome » Mon Oct 03, 2011 2:10 am

sorry i didnt notice that, i fixed it and now trine is running perfectly

thanks a lot :)

alt_turo
Posts: 195
Joined: Mon Dec 13, 2010 11:06 am

Re: ERROR: OpenGL 2.0 required

Postby alt_turo » Mon Oct 03, 2011 12:47 pm

adrenochrome wrote:about shadowgrounds source code, the archive provided by humblebundle dont seems to include any makefile-like system for linux(no install or readme found :/ )

Yeah, FB forgot those from the package :)

, i hade to use the sources from here : https://github.com/vayerx/shadowgrounds :/
what's the difference with these sources : http://code.google.com/p/shadogrounds-a ... -survivor/ ?
which of the 3 versions (bundle,googlecode,github) is the most uptodate and the most official ?

https://github.com/turol/shadowgrounds is where I put my modifications. I don't think there's a more "official" one anywhere.
Turo Lamminen
Alternative Games

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: OpenGL 2.0 required on Radeon HD5870 ?

Postby fb_joel » Fri Oct 07, 2011 9:28 pm

Ah, good to hear it works and sorry for the source code mishap, heh. :)
// Joel, Frozenbyte team


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: Google [Bot] and 3 guests