Linux Trine 2 - Minor graphical glitch, runs great on F17

Technical support for the Linux and Mac platforms for all Trine games.
xolotl
Posts: 24
Joined: Tue Apr 12, 2011 11:41 pm

Linux Trine 2 - Minor graphical glitch, runs great on F17

Postby xolotl » Sat Jul 07, 2012 12:41 am

Hello! Just noticed today that Trine 2 has had a Linux version for awhile, so that was some welcome news on a Friday where it's still too bloody hot to step outside. :)

The game in general runs great on my Fedora 17 box, for what it's worth - if you wanted to update the README in there, all of the advice for F16 should apply on F17 as well (I already had all the i686 libs installed from other games).

One very minor issue that I noticed during the first level is that there are occasional areas where there are white outlines inbetween some of the polygons. I took a couple of screenshots to show you what I mean; the first is the chest in the very opening in-game scene, and the second a bit later on in the same level, on the shingles on a rooftop:

http://i.imgur.com/Gzx93.png
http://i.imgur.com/degq9.jpg

Pretty minor, but perhaps it could bear some looking-into. I'm running the binary nVidia drivers, version 295.59, on a GeForce GTS 250, fwiw. Let me know if you could use any other technical details, though I'd imagine those would be the relevant ones.

And thanks again for the Linux port! Love your games.

alt_turo
Posts: 195
Joined: Mon Dec 13, 2010 11:06 am

Re: Linux Trine 2 - Minor graphical glitch, runs great on F1

Postby alt_turo » Wed Jul 11, 2012 12:06 pm

Those are not between the polygons but in places where the normal is at an almost-straight angle relative to camera direction. We had the exact same issue in Trine 1 Linux but it was fixed in beta.

FB guys: Check out Trine 1 Linux shader depthpass_mesh_pixel.cg line 59. There's a workaround for this issue. I have NO idea why that helps since the resulting normal should still be valid. In fact on AMD cards it is, this bug is only present on Nvidia.
Turo Lamminen
Alternative Games

xolotl
Posts: 24
Joined: Tue Apr 12, 2011 11:41 pm

Re: Linux Trine 2 - Minor graphical glitch, runs great on F1

Postby xolotl » Wed Jul 11, 2012 11:44 pm

alt_turo wrote:Those are not between the polygons but in places where the normal is at an almost-straight angle relative to camera direction. We had the exact same issue in Trine 1 Linux but it was fixed in beta.

Ah, interesting - thanks for the info.


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 4 guests