SG frame rate issue on Mac OS X

Technical support for the Linux and Mac platforms for Shadowgrounds and Shadowgrounds Survivor.
ifnotwhynot
Posts: 2
Joined: Sat Apr 16, 2011 11:06 am

SG frame rate issue on Mac OS X

Postby ifnotwhynot » Sat Apr 16, 2011 11:10 am

Hi,

I bought Shadowgrounds through the humble bundle, it's a great game and I'm loving it.

Only problem is that after about 20 minutes of play the whole game goes jerky. It's like the game skips 10 frames and freezes, skips 10 frames and freezes......

This happens every time I play and is not an intermittent issue.

Any suggestions?

I'm running it on a 2009 iMac intel core duo machine under OS 10.6.7.

Thanks.

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: SG frame rate issue on Mac OS X

Postby fb_joel » Sat Apr 16, 2011 11:30 pm

I think I have one similar issue in an email thread too, I'll post any solutions if we find one. In the meantime here's a list of things to try (one or more could do the trick, some are a bit general and not suitable for real playing, but the point is to figure out what's causing this):

- Use lower graphics settings/resolutions
- Untick Fullscreen in the Launcher/Advanced
- Disable sounds

Let me know. I'm not too sure if this will help, but at least they're worth a shot.
// Joel, Frozenbyte team

alt_tuomas
Posts: 57
Joined: Tue Apr 05, 2011 11:30 am

Re: SG frame rate issue on Mac OS X

Postby alt_tuomas » Sun Apr 17, 2011 4:24 pm

Some things you could try in the options.txt file found at the <username>/Library/Shadowgrounds/Config/ -directory:
-Disable sounds by setting "sounds_enabled = 0" in the "Sounds" subsection.
-Set "loglevel = 0" and "console_loglevel = 0" in the "Debug" subsection.

Though I'm not sure if these will help but those are what comes to my mind right now.
Tuomas Närväinen
Alternative Games

decavolt
Posts: 1
Joined: Sun Jun 03, 2012 10:29 am

Re: SG frame rate issue on Mac OS X

Postby decavolt » Sun Jun 03, 2012 10:35 am

I'm having this same problem with Shadowgrounds: Survivor. I've tried running at low resolution, disabling options and setting log levels to 0 as suggested earlier. The game plays fine for about 20 minutes, then bogs down to a near 0 frame rate. I have to quit and start again. I've also tried running the game in a window, and command-tabbing out and then back into the game as suggested elsewhere, but that doesn't work either.
Any ideas? The hour or so that I've been able to play has me really interested and wanting to play more.


Return to “Technical support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 5 guests