Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Technical support for the Linux and Mac platforms for Shadowgrounds and Shadowgrounds Survivor.
tehowe
Posts: 4
Joined: Tue Apr 26, 2011 6:31 am

Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby tehowe » Tue Apr 26, 2011 6:49 am

Hey, just bought the humble bundle - Trine works wonderfully, beautifully rendered.

Neither Shadowgrounds nor Shadowgrounds Survivor will launch though. On clicking launch in the launcher app, they simply disappear, nothing happens.

I tried running from the shell (./survivor-launcher and ./shadowgrounds-launcher) to see what happens as well, and in both cases clicking launch results in my dual monitors going black, and then returning to my Gnome desktop. The following complaint is returned by the shell before the launcher comes up though

./lib32/libxml2.so.2: no version information available (required by /usr/lib32/libglade-2.0.so.0)

I couldn't tell you if that's a good test though, since I can't launch Trine from the shell either, only from the menu shortcut.

I'm running an ATI 5850 Radeon in a hexcore AMD system, so I should have the juice. Catalyst version 11.2. What's different between Trine and the Shadowgrounds series games?

CutDaMuzik
Posts: 1
Joined: Tue Apr 26, 2011 9:27 am

Re: Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby CutDaMuzik » Tue Apr 26, 2011 9:40 am

Hello Tehowe,

Same kind of issue on my side with Ubuntu 10.10 64, but with an Nvidia 9600GT.

Trine works perfectly, but not Shadowgrounds.
Same kind of behaviour with a black screen coming back to the desktop immediately when trying to launch the game.
I have the same warning "./shadowgrounds-launcher: ./lib32/libxml2.so.2: no version information available (required by /usr/lib32/libglade-2.0.so.0)", but I don't think the issue comes from there since there seems to be some kind of memroy issue :

Code: Select all

[email protected]:~/Jeux/shadowgrounds$ ./shadowgrounds-launcher
./shadowgrounds-launcher: ./lib32/libxml2.so.2: no version information available (required by /usr/lib32/libglade-2.0.so.0)
*** glibc detected *** ./shadowgrounds-bin: malloc(): memory corruption: 0x0a225378 ***
======= Backtrace: =========
/lib32/libc.so.6(+0x6c421)[0xf6704421]
/lib32/libc.so.6(+0x6f225)[0xf6707225]
/lib32/libc.so.6(__libc_malloc+0x5c)[0xf6708e2c]
/usr/lib32/nvidia-current/libGL.so.1(+0x7e5e0)[0xf740b5e0]
======= Memory map: ========
08048000-08512000 r-xp 00000000 08:01 6283747                            /home/cutdamuzik/Jeux/shadowgrounds/shadowgrounds-bin
08512000-0851f000 rw-p 004ca000 08:01 6283747                            /home/cutdamuzik/Jeux/shadowgrounds/shadowgrounds-bin
...
Then it's dumping memory down to :

f482d000-f482f000 rw-p 00000000 00:00 0
f482f000-f4830000 r-xp 00000000 08:01 6283724                            /home/cutdamuzik/Jeux/shadowgrounds/lib32/libxcb-xlib.so.0Abandon

tehowe
Posts: 4
Joined: Tue Apr 26, 2011 6:31 am

Re: Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby tehowe » Wed Apr 27, 2011 9:58 am

How could I execute a similar backtrace to verify on this end?

I do have glibc installed, however the kinds of error messages you're seeing...

Code: Select all

*** glibc detected *** ./shadowgrounds-bin: malloc(): memory corruption: 0x0a225378 ***


...don't pop up automatically

tehowe
Posts: 4
Joined: Tue Apr 26, 2011 6:31 am

Re: Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby tehowe » Wed Apr 27, 2011 10:20 am

Found the log for survivor at ~/.frozenbyte/survivor/log.txt There's no log for shadowgrounds, but this should give the developers something to go on. This instance was from running survivor via the launcher through the Gnome menu.

Looking for ~/survivor/Data/Locales/en/* I only found ~/survivor/data/locales/pl/ (if that's relevant)

Code: Select all

27.4.2011 [3:10]

ERROR: Ambiguous filename: caveboss_uvmap.dds

ERROR: Ambiguous filename: caveboss_uvmap.dds

ERROR: Ambiguous filename: alien2_uvmap.dds

ERROR: Ambiguous filename: scythespider_uvmap.dds

ERROR: Ambiguous filename: alien_holo_shield.dds

ERROR: Failed to load locale file Data/Locales/en/cinematic_m1.txt

ERROR: Failed to load locale file Data/Locales/en/cinematic_m5.txt

ERROR: Failed to load locale file Data/Locales/en/cinematic_m12.txt

ERROR: Failed to load locale file Data/Locales/en/cinematic_m14.txt

ERROR: Failed to load locale file Data/Locales/en/gui_loadingwindow.txt

ERROR: Failed to load locale file Data/Locales/en/gui_common.txt

ERROR: Failed to load locale file Data/Locales/en/key_control_names.txt

ERROR: Failed to load locale file Data/Locales/en/gui_main.txt

ERROR: Failed to load locale file Data/Locales/en/gui_loading.txt

ERROR: Failed to load locale file Data/Locales/en/gui_mission.txt

ERROR: Failed to load locale file Data/Locales/en/gui_options.txt

ERROR: Failed to load locale file Data/Locales/en/gui_unit_combat.txt

ERROR: Failed to load locale file Data/Locales/en/gui_abort.txt

ERROR: Failed to load locale file Data/Locales/en/gui_map.txt

ERROR: Failed to load locale file Data/Locales/en/gui_progressbar.txt

ERROR: Failed to load locale file Data/Locales/en/gui_upgrades.txt

ERROR: Failed to load locale file Data/Locales/en/gui_ingame_common.txt

ERROR: Failed to load locale file Data/Locales/en/gui_unit_pointers.txt

ERROR: Failed to load locale file Data/Locales/en/gui_mainmenu.txt

ERROR: Failed to load locale file Data/Locales/en/gui_tip_items.txt

ERROR: Failed to load locale file Data/Locales/en/gui_tip_units.txt

ERROR: Failed to load locale file Data/Locales/en/gui_tutorial.txt

ERROR: Failed to load locale file Data/Locales/en/updates_gui_finspecial.txt

ERROR: Failed to load locale file Data/Locales/en/launcher_languages_override.txt

ERROR: Failed to load locale file Data/Locales/Common/gui_mod.txt

ERROR: Failed to load locale file Data/Locales/en/gui_mod.txt

ERROR: Failed to load locale file Data/Locales/Common/subtitles_mod.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mod.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission1.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission2.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission3.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission5.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission7.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission10.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission11.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission12.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission13.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mission14.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_hint_items.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_dev.txt

ERROR: Failed to load locale file Data/Locales/Common/gui_mod.txt

ERROR: Failed to load locale file Data/Locales/en/gui_mod.txt

ERROR: Failed to load locale file Data/Locales/Common/subtitles_mod.txt

ERROR: Failed to load locale file Data/Locales/en/subtitles_mod.txt

WARNING: ParserGroupData::getValue - Given key "linear_speed_x" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_y" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_x" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_y" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_x" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_y" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_x" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "linear_speed_y" does not exist, returning default value.

WARNING: ParserGroupData::getValue - Given key "enable_distortion" does not exist, returning default value.

alt_tuomas
Posts: 57
Joined: Tue Apr 05, 2011 11:30 am

Re: Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby alt_tuomas » Wed Apr 27, 2011 12:05 pm

You need to have 32 bit versions of GTK libraries and your graphics driver to run Shadowgrounds and Survivor on 64 bit Linux distros. This could be the problem here.
Tuomas Närväinen
Alternative Games

tehowe
Posts: 4
Joined: Tue Apr 26, 2011 6:31 am

Re: Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby tehowe » Wed Apr 27, 2011 11:08 pm

You need to have 32 bit versions of GTK libraries and your graphics driver to run Shadowgrounds and Survivor on 64 bit Linux distros. This could be the problem here.


How can I check on that? And will it hobble my 64 bit libs or can they coexist together?

alt_tuomas
Posts: 57
Joined: Tue Apr 05, 2011 11:30 am

Re: Neither Shadowgrounds Game launches on Ubuntu 10.10 64

Postby alt_tuomas » Fri Apr 29, 2011 12:01 pm

Yes, they can exist together with no problems. You need the package "ia32-libs" installed, use your package manager to check that. Sorry I can't really help you with the 32 bit graphics driver, you could try asking on Ubuntu forums perhaps?
Tuomas Närväinen
Alternative Games


Return to “Technical support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 1 guest