Frozenbyte games leave DPMS disabled

Technical support for the Linux and Mac platforms for Shadowgrounds and Shadowgrounds Survivor.
Hyper_Eye
Posts: 1
Joined: Wed May 04, 2011 2:14 am

Frozenbyte games leave DPMS disabled

Postby Hyper_Eye » Wed May 04, 2011 2:54 am

I have tested the Shadowgrounds games and Trine and all 3 disable DPMS without reenabling it after exiting. I ran the games from the shell to be sure they aren't crashing and they are not. I am running KDE 4.6.2.

Code: Select all

$ uname -a
Linux dmwoodlx2 2.6.38-gentoo-r4 #1 SMP Tue May 3 11:32:53 CDT 2011 x86_64 AMD Phenom(tm) II X4 975 Processor AuthenticAMD GNU/Linux

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  270.41.03  Sat Apr  9 00:06:19 PDT 2011
GCC version:  gcc version 4.5.2 (Gentoo 4.5.2 p1.1, pie-0.4.5)

$ cat /proc/driver/nvidia/gpus/0/information
Model:           GeForce 9800 GTX/9800 GTX+
IRQ:             18
Video BIOS:      62.92.5d.00.0c
Card Type:       PCI-E
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    0000:01.00.0

$ X -version

X.Org X Server 1.10.1
Release Date: 2011-04-15
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-gentoo-r1 x86_64 Gentoo
Current Operating System: Linux dmwoodlx2 2.6.38-gentoo-r4 #1 SMP Tue May 3 11:32:53 CDT 2011 x86_64
Kernel command line: root=/dev/md3 vga=0x0369 video=vesafb:mtrr:3,ywrap
Build Date: 27 April 2011  12:49:40AM

Swanny
Posts: 2
Joined: Mon May 16, 2011 1:05 pm

Re: Frozenbyte games leave DPMS disabled

Postby Swanny » Mon May 16, 2011 1:25 pm

A couple of options here but it won't be caused by the games themselves.

First thought was X.org bug 13962 affecting DPMS but your installed X.org version 1.10.1 already has the fix.

So it will likely be the included SDL library is out of date as there have a been a few changes to not switch DPMS directly. I'd suggest disabling the libSDL-1.2.so.0 library included with the game and try using your system library which should be SDL version 1.2.14 that has the changes. If still no success, try building current SDL 1.2 (not 1.3) source.


Return to “Technical support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 2 guests