Page 1 of 1

libgcc_s.so.1 must be installed for pthread_cancel to work

Posted: Sun Oct 16, 2011 6:59 pm
by slune
Hi I am getting this error:

ALSA lib pcm.c:2104:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
Fatal error: Renderer initialization failure.
See the log for details.
libgcc_s.so.1 must be installed for pthread_cancel to work
Aborted (core dumped)

System is Fedora 15 x86_64 (GeForce 9800M GTS, NVIDIA Driver Version: 280.13).
I have libgcc-4.6.1-9.fc15.i686 package is installed.

Any ideas?

Thanks

Re: libgcc_s.so.1 must be installed for pthread_cancel to wo

Posted: Mon Oct 17, 2011 3:42 pm
by fb_joel
Not quite sure, but looks like the same or similar issue is in the FAQ:

If you experience this problem (possibly on at least Fedora 14 x86_64):
[x]$ ./trine-launcher
ALSA lib pcm.c:2104snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2104snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2104snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
AL lib: alsa.c:344: Could not open playback device 'default': No such file or directory
AL lib: oss.c:179: Could not open /dev/dsp: No such file or directory

Then the fix is to
Copy /lib64/libasound.so.2 to your trine/lib64/ install.

Re: libgcc_s.so.1 must be installed for pthread_cancel to wo

Posted: Mon Oct 17, 2011 5:40 pm
by slune
It works. Thank you very much!

I was looking for the libgcc_s.so.1 must be installed for pthread_cancel to work.

Re: libgcc_s.so.1 must be installed for pthread_cancel to wo

Posted: Tue Oct 18, 2011 2:43 pm
by fb_joel
Good to hear. :)