Page 1 of 1

Shadowgrounds (Linux) freezes when firing gun

Posted: Wed Mar 14, 2012 1:21 am
by PsynoKhi0
Hi,
I've recently upgraded my computer and since then Shadowgrounds (Update 1) has been freezing as soon as I shoot.
I hear the gunshot (though no muzzle flash), game then freezes and I have to switch to a tty to kill -9 the process, while the music still plays in the background.
This happens both in Xubuntu 11.10 32 bit (PAE) and openSUSE 12.1 64 bit.

AMD FX-6100, stock speed
Asus M5A99X EVO with latest BIOS/UEFI
Kingston 8GB 1866MHz
Asus HD4830 (tried with Catalyst 12.1 and 12.2)
Brand new HDD
libasound.so.2, libasound_module_pcm_pulse.so, libopenal.so.1 removed from the lib32 folder

Not really sure where to start troubleshooting heh

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Wed Mar 21, 2012 12:35 pm
by FB_JussiE
Hello PsynoKhi0 and sorry for the long delay.

In all honesty this seems like a really odd problem and can't think of anything that should cause such an issue.

Have you tried re-downloading and installing the game (the installer might've gotten corrupted on the way) ?
Do you get any sort of error messages (try running the game from terminal and see if there's any output) ?

Again sorry for the delay.

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Mon Apr 02, 2012 12:12 pm
by PsynoKhi0
No problem, I guess you guys already have your hands full with Trine 2 :)

I downloaded the installer through bittorrent each time and checked the MD5 on each so I doubt it's the issue.
Also got a new BIOS for my motherboard (released 4 days ago). Still no go.

Could some scheduler be confused about the Bulldozer architecture?

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Thu Jun 21, 2012 12:05 pm
by PsynoKhi0
Upgraded configuration:
HD7770, Catalyst 12.6 beta
Xubuntu 12.04
Same issue.

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Fri Jun 29, 2012 4:28 pm
by PsynoKhi0
Well I finally got to poke around the various options and found that setting "Lighting Level" to anything above "Medium" caused the game to freeze.
Side note: enabling "Distortion Effects" causes the ground to be almost pitch black.

So 2 workarounds for now.

Edit: spoke too soon... I can shoot, but using the flashlight causes freezing still.

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Mon Jul 02, 2012 2:24 pm
by alt_turo
All 3 of those things use render-to-texture. This sounds like some really weird driver bug.

Flashlight resolution is affected by shadow quality setting. What happens when you set that to low?

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Tue Jul 03, 2012 10:33 pm
by PsynoKhi0
alt_turo wrote:All 3 of those things use render-to-texture. This sounds like some really weird driver bug.

Flashlight resolution is affected by shadow quality setting. What happens when you set that to low?

Same thing, even tried with global "Very low" setting.

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Fri Aug 31, 2012 8:18 pm
by Urfoex
Having the same problem in Survivor.

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Thu Sep 27, 2012 2:40 pm
by PsynoKhi0
Update: with Catalyst 12.9 beta, the game doesn't freeze, though shooting/using the flashlight causes the framerate to drop as to be unplayable.

Update 2: Catalyst 12.10 final, same thing

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Tue Feb 05, 2013 9:07 pm
by PsynoKhi0
Testing Catalyst 13.2 beta, freezing still occurs when using flashlight regardless of quality settings.
Anything from the log.txt file that could give you a hint? It's close to 1.5MB in size after just starting the game and turning the flashlight on.

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Sun May 26, 2013 2:44 pm
by PsynoKhi0
Catalyst 13.4, same thing

Re: Shadowgrounds (Linux) freezes when firing gun

Posted: Sat Mar 15, 2014 4:54 pm
by PsynoKhi0
Now running Catalyst 14.2, no difference.
However, checking the log, the last line is:
DEBUG: SoundMixer::loadSample - Loading sound sample data/sounds/defaultfx/flashlight_switch.wav

There is no "sound" folder under "data":
shadowgrounds/data$ ls
fonts glshaders models textures videos

Which is weird because I do get sounds in game.