Shadowgrounds Survivor Technical Support: Win7 x64 Problems

Have a problem with Shadowgrounds or Shadowgrounds Survivor on the Windows platform? Post here.
Huscurian
Posts: 4
Joined: Sat Aug 03, 2013 8:47 am

Shadowgrounds Survivor Technical Support: Win7 x64 Problems

Postby Huscurian » Sat Aug 03, 2013 9:06 am

Hello,

I recently purchased Shadowgrounds: Survivor from a retail store. I installed the game via Steam. I have, from past experiences, have had problems with the demos of Shadowgrounds: Survivor, Alien Shooter 1, Alien Shooter 2, and Zombie Shooter 1. I thought buying the DVD-ROM would have helped solve the problems that I have with my computer; turns out the problems continued.

I did quite a few hours of troubleshooting scouring forums, posts, to figure out what's wrong. Before I outline the methods I employed to figure out the problems despite no answer, I'll give you my specifications:

ASUS Extreme-Z ROG
16GB RAm
2x GeForce 560 GTX
Windows 7 Ultimate x64
Two monitors (not sure how that's relevant but I thought I'd put this one in)

GeForce 560 GTX v. 320.49
Ageia PhysX v. 9.12.1031

To the methods

1: DEP

I have read somewhere on the forums on Steam that DEP is potentially a problem that blocks Shadowgrounds: Survivor from playing. I followed the instructions how to employ DEP and exempt the game's executable from it. Turns out that the problems still persist. It has this error where I usually launch the game, end up right into the menu, so I mundanely select Easy, then press Start under New Game. By the time I reach the first screen, it has this loading bar that only reaches 95% then all of a sudden goes black, then crashes silently right back to the desktop. Clearly, this one isn't working.

2: Win XP SP2

Same problem as 1. The only problem is that the UAC controls are asking me to confirm yes or no to continue accessing the game. The weirdest part? Every time I do that, it says a Steam error "app is running" so it keeps doing that. However, if I disable Win XP SP2, and/or check/uncheck (doesn't matter) administrator privileges, the game will launch. It will not resort to the error under Steam. It launches as before, but crashes the same way as 1.

3: 1600x900x32 Resolution

I found that under a resolution of 1024x768x32 enables me to access the menu. However, if I ever change the resolution to 1600x900x32 or any higher than the original one, the game will NOT launch nor start the game. It will quickly shut down and return right back to the desktop.

The game has never ever made it to the mission ever... I have been able to play the first Shadowgrounds demo, but the demo of the second one is the same as this one. Alien Shooter 1, Reloaded or Revisited, Zombie Shooter, and others are refusing to acknowledge the computer and will crash the same way as 3. Zombie Driver HD has been accessible thus far so I have no idea what the problem is right now.

----

To end it all, I checked your page here: http://shadowgroundsgame.com/new/index. ... uble_start

I have fulfilled all the requirements. I have not found one iota of any problem regarding my computer as it has been sufficient to meet the requirements to run the game. However, it is said at the end that I am to contact FrozenByte as it could be a problem that can be solved on your end, hence my first post here.

I hope we can resolve this problem because this is driving me crazy, honestly.

User avatar
AnniFB
Posts: 96
Joined: Tue May 21, 2013 4:45 pm
Contact:

Re: Shadowgrounds Survivor Technical Support: Win7 x64 Probl

Postby AnniFB » Mon Aug 05, 2013 10:56 am

Luckily there's should be one thing that could fix this! :)

http://www.nvidia.com/object/physx-9.12 ... river.html

This installer is required for games released around the end of 2007. If a game released in that period worked correctly with PhysX System Software 9.12.0613 but no longer works with latter versions the legacy installer is required. So this is worth a try. Let me know how it goes!

Huscurian
Posts: 4
Joined: Sat Aug 03, 2013 8:47 am

Re: Shadowgrounds Survivor Technical Support: Win7 x64 Probl

Postby Huscurian » Mon Aug 05, 2013 8:07 pm

AnniFB wrote:Luckily there's should be one thing that could fix this! :)

http://www.nvidia.com/object/physx-9.12 ... river.html


That is weird. I clicked on the link you sent me. It took me straight to the page regarding the legacy installer. As I confirmed the "download", it takes me to a blank page where there's no downloading. I can't even download, even if I did a fresh copy and paste+search. Did Nvidia forget to put that one up or is it gone now?

I have checked more than once using different broswers: Firefox, Chrome. It turns out the page is non-existent. It won't publish the page where I could easily download the driver. I have messaged the GeForce forums asking why the page doesn't exist. I may hear more from them soon.

That sucks though. If Nvidia really did take it down, I really have no idea as to how I could play this game; I was hoping, really hoping, this is the only thing I need to do to rectify the errors I have had.

I downloaded this from here. Turns out that when I downloaded it, attempted to install it, it said I have the newest version possible. I see a difference of the file there and Nvidia's page concerning MB. Physxinfo.com's file is 25mb while Nvidia's is 19.2mb so I wouldn't know. I may remove the current version of Physx, install that one file, and then install the other to see if it works.

The file I downloaded straight from physxinfo.com was installed. I attempted to play Shadowgrounds Survivor but turns out that the game won't work after the loading screen at 95%. The problem still persists. Honestly, I have no idea what's causing it to be shut down.

I'll be installing the newest and current version to see if it works in concert with the legacy installer but not sure. I'll keep you posted. After several editing, I've found that the newest version overwrites the installed version I put in. It won't work. It still hits 95% on New Game, Survival (Spider level), and will crash right back to the desktop.

*Special Note: Physxinfo.com's download wasn't the legacy driver I was looking for. Turns out it is almost the current and newest version. They did a special linking to the same one you linked me to. The page still remains non-existent after clicking download.

PROBLEM SOLVED: I found the Legacy Installer. When you directly linked me to it, it refused to open the download page. I had to access a very special part of Nvidia to download it. I've been playing Shadowgrounds Survivor a while ago and beat the whole game! Found 10 out 20 secrets. ;)

Thank you very much for a great game, Frozenbyte!

User avatar
AnniFB
Posts: 96
Joined: Tue May 21, 2013 4:45 pm
Contact:

Re: Shadowgrounds Survivor Technical Support: Win7 x64 Probl

Postby AnniFB » Thu Aug 08, 2013 8:49 am

Glad to hear! Hope you enjoy playing! :D


Return to “Technical Support for Windows”

Who is online

Users browsing this forum: No registered users and 8 guests