Page 1 of 1

Another Bug in Mission 9

Posted: Tue Feb 07, 2006 7:56 pm
by Guest
I think there is a bug in mission 9.

I played with COOP and then there was no door that opens (I think I had the chip-card, but I died)

In front of the door there are glasses that couldn't be destroyed.

I use the inofficial patch 1.01

PS: After I minisized the game to make the screenshot, the game made an memory-error and had to end.

Here's a screen of the map:
http://www.daniel-marschall.de/files/map.JPG

#Daniel Marschall

Posted: Tue Feb 07, 2006 8:22 pm
by Sampo
The indestructable windows are there on purpose; the place that's beyond the door is supposed to be sterile, I think. The door to that place opens after you've aligned the spaceship and installed the software and engines.

Posted: Tue Feb 07, 2006 8:39 pm
by Guest
Hello.

I have done those jobs, I installed the software.

Posted: Tue Feb 07, 2006 8:54 pm
by Sampo
What about the engine? For that you have to bring the ship to an other room.

I think I have encountered the same door bug... If you have installed the engine and the software, then there is no option but to restart the level.

Posted: Tue Feb 07, 2006 8:57 pm
by Guest
That means I have to find FIRST the amew bomb and THEN I have to install engine/software?

Posted: Tue Feb 07, 2006 9:50 pm
by Sampo
No, getting AMEW is the last mission before the next level.

Posted: Tue Feb 07, 2006 10:19 pm
by Guest
I played this level over 3 times and there is no way to complete it with COOP and the inofficial patch 1.01 (German).

I tried following:
1. First engine and then software
2. First software and then engine

This makes no difference, the doors to the AMEW-Bomb is locked (look at the screenshot in post #1).

And after I have done the 2 jobs, the AMEW-Bomb-Job activated.

I even tried the opendoor-cheat, but it don't work... I am very disappointed with this level... I can't go to the next level, that makes me angry.

#Daniel Marschall

Posted: Tue Feb 07, 2006 11:55 pm
by dizzy_2.0
I got the same problem... It's quite disappointing if you're playing the game with a friend and when it's getting interessting (I told him about the 2 Mechs...) this stupid door doesn't open and you can't do anything...

Posted: Fri Feb 10, 2006 3:33 pm
by Guest
No statement from the developer?

Posted: Sat Feb 11, 2006 12:18 am
by fb_jpk
As far as I know, this door issue should have been fixed in the 1.01 patch by the script programmer... But I'll look into this next monday.

In addition to the actual work time game testing, I have recently played the game through in coop mode with my friend, and haven't had any problems with the door in question. Of course, that does not mean that there wouldn't be a bug... it does mean however, that the bug is not always that easy to replace and solve.

Anyway, as I said above, I'll be looking into this and hopefully the bug will be fixed in some future patch, or if I happen to find the cause of the bug quickly, I'll probably be posting some "quick fix" script file or a console command here on the forums to get past that door.

I'm guessing that the bug appears when some certain conditions are met and if you were to play the level again, you might get through the door without any problem.

Posted: Sat Feb 11, 2006 12:35 am
by Guest
Hello.

I played it 4 times with my friend and the bug is always the same.

I really want to play the last 2 levels. I tried the cheats opendoor, giveallkeys and openallremote doors, but this last door is always closed.

I will wait for the final patch, but isn't there any tempoary solution?

Posted: Sat Feb 11, 2006 1:09 am
by fb_jpk
Ok, I just noticed that this door in question was actually another door than what I thought.. In any case, I'll be looking into it...

Posted: Sat Feb 11, 2006 1:28 am
by fb_jpk
Ok, I may have a temporary solution to get around this bug...

Please notice that the following is a totally unofficial "hack" to get past the door in question. It may or it may not work properly, so you should only use it in case you cannot get past the door in any other way. (in other words, try this method only when you're sure that you have done all the objectives and that you are supposed to get past the door. If you use this unnecessarily, you may get the level even more mixed up.)

First, make sure you have installed the flight software and engine to the ship. Then walk to the sterilization room (the small room with the unbreakable glasses), make sure all the players are in that room. At this point the door should normally open.

If the door does not open, open the game console by pressing F8.
type the following into the console:

Code: Select all

startScriptProcess m12_let_player_in


Please notice the letter case (it is case sensitive).

Then proceed to get the AMEW.... When you are returning after getting the AMEW, type the following to console if the door still does not open:

Code: Select all

startScriptProcess m12_let_player_out


I haven't really had the time to test this out. It should do the trick assuming that the bug has not affected the game's ability to load the level scripts... If this helps you / it is does nothing, let me know. More info will help isolate the bug.
[/code]

Posted: Sun Feb 12, 2006 2:43 am
by Guest
Thank you, I will post here, if it works or not. I'll play this level in COOP with my friend, when he got time.

Posted: Sun Feb 19, 2006 7:48 pm
by Guest
The 2 commands had solved the problem.