Shadowgrounds Refuses to Run in Windowed Mode

Have a problem with Shadowgrounds or Shadowgrounds Survivor on the Windows platform? Post here.
Izzhov
Posts: 1
Joined: Wed Apr 13, 2011 6:57 am

Shadowgrounds Refuses to Run in Windowed Mode

Postby Izzhov » Wed Apr 13, 2011 7:00 am

I am running it in Windows 7, and I've tried everything. I've tried adding -win to the end of the shortcut, editing options.txt so that windowed = 1 and window_titlebar = 1 and maximize_window = 0, I unchecked the "fullscreen" box in the launcher in advanced options, I've tried changing the resolution, and nothing has worked. Does anyone have any idea how I can get this game to run in a window?

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: Shadowgrounds Refuses to Run in Windowed Mode

Postby fb_joel » Sat Apr 16, 2011 10:26 pm

Sorry to hear. I think this could be a problem with options.txt - try to do all those and then write-protect options.txt so that the game can't write to the files at all. Then run the Launcher again. Also just to make sure, you don't have two different versions of the game? I.e. if you use a shortcut to run, and edit the options.txt in some other folder...

Another thing is to make the edits, and then launch trine.exe directly.

Are you running the Steam version or standalone? Try vice versa if bandwidth isn't a problem, so we can see if it happens on both versions.

Please post your system specs just in case too. Maybe your graphics drivers could be doing something weird like forcing a certain resolution (no idea if this is even possible technically but I've seen enough weird things to suggest something like this).

Let me know!

(The Shadowgrounds games don't support command line options (afaik).)
// Joel, Frozenbyte team

Jellodyne
Posts: 1
Joined: Sat Jan 04, 2014 2:59 am

Re: Shadowgrounds Refuses to Run in Windowed Mode

Postby Jellodyne » Sat Jan 04, 2014 3:15 am

I have the same issue. The game appears to be running in a 'fullscreen window' at my desktop resolution rather than a real window with edges and stuff the size I want. The issue is compounded by the fact that I have an absurdly wide multimonitor desktop aspect ratio, so the game running 'fullscreen window' is unusably wide and running in 'real' fullscreen' gets me a copy on each monitor (which is at least playable, but annoying). 'm running on an ATI 5870 Eyfinity 6 card, 3 monitors wide on 2048x115s monitors, so my desktop resolution is 6144x1152. As you can imagine, the menus look a bit pinched at a 48:9 aspect ratio. I'm using Windows 7 64 bit, launching from Steam. I'm editing the options.txt located at C:\Program Files (x86)\Steam\steamapps\common\Shadowgrounds\Config\options.txt.

User avatar
FB_Teemu
Posts: 6
Joined: Thu Jan 31, 2013 12:50 pm

Re: Shadowgrounds Refuses to Run in Windowed Mode

Postby FB_Teemu » Wed Jan 15, 2014 12:36 pm

Jellodyne wrote:As you can imagine, the menus look a bit pinched at a 48:9 aspect ratio. I'm using Windows 7 64 bit, launching from Steam. I'm editing the options.txt located at C:\Program Files (x86)\Steam\steamapps\common\Shadowgrounds\Config\options.txt.


Just to check: how have you configured your display settings? To get a movable window, they should be like this (with the resolution set to what you want):

Code: Select all

maximize_window = 0
screen_height = 1080
screen_width = 1920
window_titlebar = 1
windowed = 1


Return to “Technical Support for Windows”

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest