[Linux] Shadwen fails to launch because of no libpng12.so.0

Shadwen is a stealth game, where sneaking is not optional. It was released in May 2016 for Windows, Linux, Mac and PlayStation 4.
shmerl
Posts: 36
Joined: Sun Aug 09, 2015 9:25 pm

[Linux] Shadwen fails to launch because of no libpng12.so.0

Postby shmerl » Wed May 18, 2016 3:17 am

I bought GOG version, and now I'm getting this:

Code: Select all

Running Shadwen
./bin/shadwen_linux_launcher_64bit: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

libpng 1.2 is already deprecated and doesn't exist in Debian. Can you use libpng 1.6 instead?

Same bug plagues Trine 3 by the way.

shmerl
Posts: 36
Joined: Sun Aug 09, 2015 9:25 pm

Re: [Linux] Shadwen fails to launch because of no libpng12.s

Postby shmerl » Wed May 18, 2016 3:24 am

Running it directly avoids the problem (since only the launcher depends on the invalid library):

Code: Select all

LD_LIBRARY_PATH=/opt/games/shadwen/game/lib/lib64 bin/shadwen_linux_64bit


But result was hanging with the mouse cursor wasn't moving and it didn't even react to keyboard, so I had to kill the process from the tty (Ctrl+Alt+F1) which still worked. I'll do some more tests, but so far the game is unplayable.

shmerl
Posts: 36
Joined: Sun Aug 09, 2015 9:25 pm

Re: [Linux] Shadwen fails to launch because of no libpng12.s

Postby shmerl » Wed May 18, 2016 3:38 am

OK, the hanging happened apparently because without running the launcher, game wasn't properly configured. I managed to start the launcher by copying libpng12 from Debian Jessie into the game's lib/lib64 directory.

To developers: can you please either ship libpng12 with the game, or even better, switch to up to date library?

User avatar
FB_JussiE
Posts: 267
Joined: Wed Nov 23, 2011 4:09 pm
Location: Finland
Contact:

Re: [Linux] Shadwen fails to launch because of no libpng12.s

Postby FB_JussiE » Thu May 19, 2016 9:46 am

Hi shmerl!

I think the dependency is indirect one via WXWidgets, which would explain it being required only by the launcher (haven't checked tho, but would make sense).

We'll take a look if the dependency could be dropped or bundled with the game, but currently I do not know about our patching schedule so it could take some time.


Return to “Shadwen”

Who is online

Users browsing this forum: No registered users and 8 guests