Page 1 of 1

[Linux] Mouse lagging issues

Posted: Wed May 18, 2016 3:52 am
by shmerl
At least in the main menu and in settings menu, mouse is noticeably lagging at times. Changing mouse sensitivity doesn't fix it. I can't yet explain what is causing it. So far didn't test it in the actual game.

System: Debian testing x86_64 / KDE Plasma 5.
GPU: Nvidia GTX 680 (closed driver 361.42).
Fullscreen window compositing is disabled.

Re: [Linux] Mouse lagging issues

Posted: Wed May 18, 2016 3:57 am
by shmerl
Looks like inside the game mouse works OK. It must be something menu UI related.

Re: [Linux] Mouse lagging issues

Posted: Wed May 18, 2016 6:27 am
by shmerl
Another report from here:

[SYSTEM]
Phenom II X4 945 3.0Ghz
8 GB RAM
Two AMD Radeon 6870s
AMD Driver Ver: 15.201.1151-10
OS: Manjaro 64-Bit w/ Kernel 4.1.24-1

[GAME SETTINGS]
Resolution: 1920 x 1080
Window: Automatic
AA: Off
Vert. Sync: Off
Graphics Level: Variable, as listed below

[RESULTS]
Single GPU, "Very High" graphics: High UI lag, game stuttering (guessing around 10 to 15 fps)
Single GPU, "Very Low" graphics: No UI lag, no stuttering
Single GPU, "Med" graphics: Some UI lag, stuttering noticeable, but playable
Crossfire GPUs, "Very High" graphics: very low UI lag, minimal game stuttering.

Re: [Linux] Mouse lagging issues

Posted: Wed May 18, 2016 1:40 pm
by EllaFB
Unfortunately we haven't run into this kind of problem in our office. You said that changing the mouse sensitivity does not help. Just to make sure, you should double check that you don't have any accelerator feature for your mouse turned on.

We have forwarded this issue to our QA, so we'll look into it if necessary. But sounds like the issue is fairly small, so I don't know if we should or can do anything about it.

Sorry for the inconvenience!

Re: [Linux] Mouse lagging issues

Posted: Wed May 18, 2016 6:11 pm
by shmerl
My mouse is Logitech G400s with standard out of the box Linux support. It has hardware DPI adjusting buttons which are adjusting the mouse itself, not the system. I'll run some tests with other mouse, to see if it makes any difference.

Re: [Linux] Mouse lagging issues

Posted: Wed May 18, 2016 11:03 pm
by shmerl
Changing

Code: Select all

setOption(inputModule, "InputUpdateInterval", 8)

to

Code: Select all

setOption(inputModule, "InputUpdateInterval", 4)


in $HOME/.local/share/frozenbyte/Shadwen/options.txt reduces mouse lag in the UI. But it also changes mouse behavior in game (limiting turning range), so it's not really a good workaround.

I suspect there is some heavy activity that's going on in the UI, that slows down the input responsiveness. Some profiling can help may be. Or may be it's artificially reduced there for some reason?

Re: [Linux] Mouse lagging issues

Posted: Sat May 21, 2016 9:09 pm
by Ternvein
I can confirm the issue.
Mouse moves strangly and lagging in the menu. Sometimes it's even hard to point it to the button.
Mouse: A4Tech X7, built-in Linux drivers.

Re: [Linux] Mouse lagging issues

Posted: Thu May 26, 2016 2:05 pm
by MarjutFB
Sorry for the delay!

And unfortunately we don't have a fix. I'm sorry for the incontinence! :( However good if your mouse seems to work fine in-game.

Re: [Linux] Mouse lagging issues

Posted: Thu May 26, 2016 7:04 pm
by shmerl
MarjutFB wrote:And unfortunately we don't have a fix.


Did you at least manage to reproduce the problem? If you don't have this issue, may be it can help narrowing down conditions under which it occurs.

Re: [Linux] Mouse lagging issues

Posted: Fri May 27, 2016 1:07 pm
by MarjutFB
shmerl wrote:Did you at least manage to reproduce the problem? If you don't have this issue, may be it can help narrowing down conditions under which it occurs.


I checked this from our QA team and they confirmed we haven't managed to reproduce this. We have gotten a couple more reports about this on Steam, but seems like it isn't happening to majority.

Re: [Linux] Mouse lagging issues

Posted: Mon Jun 20, 2016 4:00 am
by spxip
Hey, I also had this problem and I was able to find a workaround in my case at least. In the file
~/.local/share/frozenbyte/Shadwen/options.txt I had lines

Code: Select all

setOption(inputModule, "RawInputMiceEnabled", false)
setOption(inputModule, "RawInputJoysticksEnabled", true)

and after setting RawInputMiceEnabled to true and RawInputJoysticEnabled to false my game menu lag disappeared.

Re: [Linux] Mouse lagging issues

Posted: Mon Jun 20, 2016 2:03 pm
by MarjutFB
spxip wrote:Hey, I also had this problem and I was able to find a workaround in my case at least. In the file
~/.local/share/frozenbyte/Shadwen/options.txt I had lines

Code: Select all

setOption(inputModule, "RawInputMiceEnabled", false)
setOption(inputModule, "RawInputJoysticksEnabled", true)

and after setting RawInputMiceEnabled to true and RawInputJoysticEnabled to false my game menu lag disappeared.

I'm glad you found a solution and thank you for sharing it! This might be helpful for others. :)

I hope you enjoy playing!

Re: [Linux] Mouse lagging issues

Posted: Mon Jun 20, 2016 8:26 pm
by spxip
I think I spoke too soon with this workaround. After I got my red graphics fixed, I tried to play the game and I got same problem that OP got, limited view angles. Only way to be able to change my camera angle more than the limited range was that I pressed ESC, moved my mouse cursor to other side of the screen, pressed ESC again to get back in game and then I could move my camera angle in new limited area. So I also had to revert the settings I mentioned earlier. Ah well.