[Linux] Weird red graphics

Shadwen is a stealth game, where sneaking is not optional. It was released in May 2016 for Windows, Linux, Mac and PlayStation 4.
spxip
Posts: 4
Joined: Mon Jun 20, 2016 3:34 am

[Linux] Weird red graphics

Postby spxip » Mon Jun 20, 2016 4:53 am

Hey,
I have really weird red graphics when I start Shadwen. This happens in game menu and during the game. I have not tested to play out the game more than starting a new game, so I don't know if the game is going to crash in a long run. When I start the game from console (./start.sh) and after I accept the launcher settings, the game only gives these lines:

Code: Select all

Running Shadwen
nohup: redirecting stderr to stdout


Other errors I get from dmesg:

Code: Select all

[  219.921522] shadwen_linux_6[2810]: segfault at 7f9f22ae0fa0 ip 00007f9f1f8a77c5 sp 00007ffcc445e410 error 4 in libc-2.19.so[7f9f1f829000+1ba000]
[  244.460218] shadwen_linux_6[2875]: segfault at 7f2786252700 ip 00007f2780c847c5 sp 00007fff4a136210 error 4 in libc-2.19.so[7f2780c06000+1ba000]
[  284.431447] traps: shadwen_linux_6[2935] general protection ip:7f2866cb17c5 sp:7ffe45025ba0 error:0 in libc-2.19.so[7f2866c33000+1ba000]
[  361.738018] traps: shadwen_linux_6[3022] general protection ip:7f0b7cce57c5 sp:7ffcb2ee2b80 error:0 in libc-2.19.so[7f0b7cc67000+1ba000]


Here is an example picture from my game menu:
Shadwen.png

I tried different graphic settings from game launcher and I also tried changing settings from ~/.local/share/frozenbyte/Shadwen/options.txt but nothing helped.

System information:

Code: Select all

Linux Yuni 3.19.0-61-generic #69~14.04.1-Ubuntu SMP Thu Jun 9 09:09:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
KDE Plasma 4
GTX 660 Ti (NVIDIA binary driver - version 364.19)

User avatar
MarjutFB
Posts: 258
Joined: Tue Dec 03, 2013 3:48 pm
Contact:

Re: [Linux] Weird red graphics

Postby MarjutFB » Mon Jun 20, 2016 1:54 pm

I'm sorry to hear that you're having trouble with the game, but here is something that might help:

We have heard about a similar issue with Trine, which apparently was fixed by turning Anisotropic Filtering off from the NVIDIA Control Panel. You can find this option from the "Manage 3D settings" option.

I hope this helped, but if it didn't please let me know and we'll look into this.

Cheers!

spxip
Posts: 4
Joined: Mon Jun 20, 2016 3:34 am

Re: [Linux] Weird red graphics

Postby spxip » Mon Jun 20, 2016 5:35 pm

Thank you for the quick reply. The solution you gave worked like a charm! :D


Return to “Shadwen”

Who is online

Users browsing this forum: No registered users and 5 guests