[Linux] Can't Alt-tab or change virtual deskop

Technical support for the Linux and Mac platforms for all Trine games.
rychlis
Posts: 3
Joined: Wed Apr 13, 2011 10:26 pm

[Linux] Can't Alt-tab or change virtual deskop

Postby rychlis » Wed Apr 13, 2011 10:45 pm

Hi,

first of all, I want to thank You very much for porting this awesome game to linux!

Unfortunately there is one issue which is common for many linux ports (but not for all of them, for example Heroes of Newerth doesn't have this issue) - when i launch the game, the only way to get out of it is to quit the game. Windows manager keyboard shortcuts like Alt-tab or ctrl+alt+arrow doesn't work, because the game is capturing whole keyboard/mouse input, even in windowed mode.

This is really frustrating, so for now I'm still playing the windows version through wine :|

Is there any workaround for this?
I'm using arch linux with gnome (kernel 2.6.38-ARCH x86_64, gnome 2.32.1, metacity 2.30.3).

Thanks for any help!

alt_tuomas
Posts: 57
Joined: Tue Apr 05, 2011 11:30 am

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby alt_tuomas » Thu Apr 14, 2011 11:05 am

You can use Ctrl-G to grab/ungrab mouse input in windowed mode.
Tuomas Närväinen
Alternative Games

rychlis
Posts: 3
Joined: Wed Apr 13, 2011 10:26 pm

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby rychlis » Thu Apr 14, 2011 11:35 am

alt_tuomas wrote:You can use Ctrl-G to grab/ungrab mouse input in windowed mode.

Thank You, that works! I can finally ditch the windows version :)

Still, it would be nice to have this possibility in fullscreen mode as well, however for now i can just start the game windowed (with max resolution) and switch it to fullscreen using metacity keyb. shortcut.

Beemer5770
Posts: 1
Joined: Sun Apr 17, 2011 1:55 am

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby Beemer5770 » Sun Apr 17, 2011 1:56 am

Use Alt-Enter to go from full to windowed, then Ctrl-G to take back the mouse. Alt-Enter on the game will make it full screen again.

Beemer

kepi
Posts: 2
Joined: Sun Apr 17, 2011 12:36 pm

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby kepi » Sun Apr 17, 2011 12:45 pm

Thanks for tips!

It will be nice if there will be some possibility to run in windowed fullscreen. Sounds odd but this seems only way how to run trine ok on my dual head setup. i.e. World of warcraft has this possibility.

When I run Trine fullscreen, it appears in center of my two monitors so center of game is splitted with edge of monitor. Correct behaviour will be to run it on left or right monitor, not on whole screen. I'm able to play while turn into windowed mode but top window decorations are interrupting.

If you have any tip, let mi now. Unfortunatelly it seems that gnome-shell is unable to switch trine into fullscreen with ctrl+enter, other programs can without problem.

KameZero
Posts: 15
Joined: Sat Apr 16, 2011 5:28 pm

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby KameZero » Sun Apr 17, 2011 6:38 pm

kepi wrote:Thanks for tips!

It will be nice if there will be some possibility to run in windowed fullscreen. Sounds odd but this seems only way how to run trine ok on my dual head setup. i.e. World of warcraft has this possibility.

When I run Trine fullscreen, it appears in center of my two monitors so center of game is splitted with edge of monitor. Correct behaviour will be to run it on left or right monitor, not on whole screen. I'm able to play while turn into windowed mode but top window decorations are interrupting.

If you have any tip, let mi now. Unfortunatelly it seems that gnome-shell is unable to switch trine into fullscreen with ctrl+enter, other programs can without problem.


Hmm, depending on how savvy you are you could change to a gnome/openbox setup. Having openbox as the actual WM allows you much more granular control over windows than gnome. I run a dual head setup and just use openbox settings to make the Trine window always open on my left monitor without any window decorations. This more or less makes it fullscreen. I do this for all of my games, actually.

rewind
Posts: 2
Joined: Wed Apr 20, 2011 9:51 pm

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby rewind » Wed Apr 20, 2011 10:13 pm

To rychlis - I'm using a script on Arch for playing anything in new x-server at ctrl+alt+F8. You can try it from AUR - xlaunch. It's quite appropriate when running compiz and for alt+tab functionality, well actually ctrl+alt+F7 and ctrl+alt+F8 functionality :)

I was wondering - is there a way to change the default resolution in linux, maybe in some configuration file ?

User avatar
fb_joel
Site Admin
Posts: 2482
Joined: Fri Feb 18, 2005 2:14 pm
Location: Finland

Re: [Linux] Can't Alt-tab or change virtual deskop

Postby fb_joel » Thu May 05, 2011 7:20 pm

(Sorry for the long delay.)

You should be able to change the resolutions in the launcher, or alternatively in the config/options.txt file. The launcher's options can probably be changed in data/misc/launcher_conf.txt as well if you really need to modify those defaults (not sure why but it should be possible).

I'm not 100% sure if this works in the Linux version, but you could try changing "maximize_window = 0" and "windowed = 0" properties in config/options.txt, and see if that achieves windowed mode with maximized window. It works in the Windows version but it's possible that it's been disabled in the Linux version intentionally.
// Joel, Frozenbyte team


Return to “Trine Technical Support for Linux & Mac”

Who is online

Users browsing this forum: No registered users and 4 guests